Site ID format adds extra spaces that "error" login from Publii app

Greetings all!

Just set up a new site, and was getting a “Error! Application was unable to connect with your server” while trying to use Publii desktop app. One thing I eventually noticed is that a double-click-select, copy- and-paste inserted about five empty spaces in front of the site ID. Once I removed the empty spaces the sync went ahead fine.

Is there a way to remove those extra spaces from the site ID format in Netlify to avoid confusing nOoBs like me?

BTW, no such problems with selecting and copying the Netlify token, which did not add any extra spaces.

thanks heaps,

NOTaninja

Hi @notaninja, welcome to the Netlify Forums!

Yea, I’ve occasionally run into that issue myself. I tend to just highlight that text instead of double-clicking the text. The reason that text behaves differently from the Personal Access Token is because they are in different html elements. The first is inside a

, while the personal access token is in a
  • and behave that way due to the browser.

    One way to resolve this issue, you may want to consider installing a clipboard app like what is mentioned here: https://apple.stackexchange.com/questions/66118/how-to-remove-leading-or-trailing-spaces-from-copy-paste-operations which removes whitespace character as an option.

    Hope that helps.