Site fails to update: "There is no log for this deploy"

11:47:40 AM: There is no log for this deploy
  • Environment variables: HUGO_VERSION set to 0.91.2
  • Local builds (on my computer): passing with Hugo 0.91.2
  • I checked that the github repo that it deploys from is up to date
  • Build image: Ubuntu Focal 20.04 (default). I also tried with Ubuntu 16.04, no change.
  • Tried β€œClear cache and deploy site”: No change.

hi there,

could you try again, please? this is usually just a temporary issue.

if the problem persists, do let us know.

I tried again, the issue persists. It’s been this way for more than five weeks, actually.

In the meantime I tried with a variety of HUGO_VERSIONs (from 0.80.0 to 0.95.2) yesterday but there’s no change. (All of them work on my local machine.)

ok that is definitely odd, and I am sorry we’ve been slow to reply here.

I’m going to try and see if we can figure out what is going on!

one question i have - do you have more than one site on netlify? If no, could you make a small (a very simple, a starter site with hugo?)and deploy that so we can try and narrow down the issue.

Thanks perry.

I deployed a starter site at https://quiet-biscuit-392346.netlify.app/

I made some test changes after publishing it, the deploys appear to be working, along with a populated deploy log.

One difference I noticed in the directory organization of the test site and mine.

The test site looks like:

.
β”œβ”€β”€ bin
β”œβ”€β”€ site
β”‚   β”œβ”€β”€ content
β”‚   β”‚   β”œβ”€β”€ contact
β”‚   β”‚   β”œβ”€β”€ post
β”‚   β”‚   β”œβ”€β”€ products
β”‚   β”‚   └── values
β”‚   β”œβ”€β”€ data
β”‚   β”œβ”€β”€ layouts
β”‚   β”‚   β”œβ”€β”€ _default
β”‚   β”‚   β”œβ”€β”€ partials
β”‚   β”‚   β”œβ”€β”€ post
β”‚   β”‚   └── section
β”‚   └── static
β”‚       β”œβ”€β”€ admin
β”‚       └── img
└── src
    β”œβ”€β”€ css
    β”‚   └── imports
    β”œβ”€β”€ fonts
    └── js
        └── cms-preview-templates
            └── components

My site looks like

.
β”œβ”€β”€ archetypes
β”œβ”€β”€ content
β”‚   β”œβ”€β”€ blog
β”‚   β”œβ”€β”€ resources
β”‚   └── software
β”œβ”€β”€ data
β”‚   └── comments
β”œβ”€β”€ layouts
β”‚   β”œβ”€β”€ blog
β”‚   β”œβ”€β”€ _default
β”‚   β”œβ”€β”€ partials
β”‚   β”œβ”€β”€ shortcodes
β”‚   └── software
β”œβ”€β”€ resources
β”‚   └── _gen
β”œβ”€β”€ static
β”‚   β”œβ”€β”€ css
β”‚   β”œβ”€β”€ img
└── themes
    β”œβ”€β”€ cactus
    └── cocoa

That is, the root my site’s repo corresponds to the site subdirectory of the test website’s. I’m guesssing this is not an issue since it’s worked fine for years now.

Are you sure the starter you used is also based on Hugo? If not, it most likely needs a different organization structure.

The starter is the site that Metrology Netlify provides as an example for Hugo.

Well, in that case, as long as it’s not causing problems, it should be good to go.

Sorry, I didn’t follow. Did you mean β€œSo long as the starter site is good to go”?

I meant to say it’s the example Hugo site that Netlify provides.

Hi @karthink ,

It appears this was an issue with stuck builds that has been cleared. I can see that you now have successful deploys with build logs :tada: Let us know if you still need help on this!

It’s working again, thank you for looking into it! Cheers

1 Like