Home
Support Forums

Site Deploy Failed - Need Guidance Please

@perry , @hrishikesh

Dear Sir, Need your support in solving this.

Getting Deploy Failed

1:39:45 AM: Build ready to start
1:39:47 AM: build-image version: d84c79427e8f83c1ba17bcdd7b3fe38059376b68
1:39:47 AM: build-image tag: v3.6.1
1:39:47 AM: buildbot version: 3f7ff7bbf92b8c2ecf180659ea5b1472b472d308
1:39:47 AM: Fetching cached dependencies
1:39:47 AM: Starting to download cache of 389.8MB
1:40:01 AM: Finished downloading cache in 14.6469282s
1:40:01 AM: Starting to extract cache
1:40:13 AM: Finished extracting cache in 12.035156687s
1:40:13 AM: Finished fetching cache in 26.8006508s
1:40:13 AM: Starting to prepare the repo for build
1:40:18 AM: Preparing Git Reference refs/heads/master
1:40:26 AM: Different publish path detected, going to use the one specified in the Netlify configuration file: ‘_site’ versus ‘_site/’ in the Netlify UI
1:40:26 AM: Different functions path detected, going to use the one specified in the Netlify configuration file: ‘dist/lambda’ versus ‘’ in the Netlify UI
1:40:26 AM: Different build command detected, going to use the one specified in the Netlify configuration file: ‘npm run build’ versus ‘jekyll serve’ in the Netlify UI
1:40:26 AM: Starting build script
1:40:26 AM: Installing dependencies
1:40:26 AM: Python version set to 2.7
1:40:27 AM: Started restoring cached node version
1:40:30 AM: Finished restoring cached node version
1:40:31 AM: Downloading and installing node v10.23.3…
1:40:31 AM: Downloading https://nodejs.org/dist/v10.23.3/node-v10.23.3-linux-x64.tar.xz
1:40:32 AM: Computing checksum with sha256sum
1:40:32 AM: Checksums matched!
1:40:34 AM: Now using node v10.23.3 (npm v6.14.11)
1:40:34 AM: Started restoring cached build plugins
1:40:34 AM: Finished restoring cached build plugins
1:40:34 AM: Attempting ruby version 2.6.2, read from environment
1:40:35 AM: Using ruby version 2.6.2
1:40:36 AM: Using PHP version 5.6
1:40:36 AM: Started restoring cached ruby gems
1:40:36 AM: Finished restoring cached ruby gems
1:40:36 AM: Installing gem bundle
1:40:36 AM: [DEPRECATED] The --path flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use bundle config set --local path '/opt/build/cache/bundle', and stop using this flag
1:40:36 AM: [DEPRECATED] The --binstubs option will be removed in favor of bundle binstubs --all
1:40:38 AM: Fetching gem metadata from https://rubygems.org/
1:40:39 AM: Fetching gem metadata from https://rubygems.org/.
1:40:39 AM: Resolving dependencies…
1:40:39 AM: Using public_suffix 4.0.6
1:40:39 AM: Using bundler 2.2.5
1:40:39 AM: Using colorator 1.1.0
1:40:39 AM: Using concurrent-ruby 1.1.8
1:40:39 AM: Using eventmachine 1.2.7
1:40:39 AM: Using http_parser.rb 0.6.0
1:40:39 AM: Using ffi 1.14.2
1:40:39 AM: Using forwardable-extended 2.6.0
1:40:39 AM: Using rb-fsevent 0.10.4
1:40:39 AM: Using rexml 3.2.4
1:40:39 AM: Using liquid 4.0.3
1:40:39 AM: Using mercenary 0.4.0
1:40:39 AM: Using rouge 3.26.0
1:40:39 AM: Using safe_yaml 1.0.5
1:40:39 AM: Using unicode-display_width 1.7.0
1:40:39 AM: Using addressable 2.7.0
1:40:39 AM: Using em-websocket 0.5.2
1:40:39 AM: Using pathutil 0.16.2
1:40:39 AM: Using terminal-table 2.0.0
1:40:39 AM: Fetching i18n 1.8.9
1:40:39 AM: Using sassc 2.4.0
1:40:39 AM: Using rb-inotify 0.10.1
1:40:39 AM: Using kramdown 2.3.0
1:40:39 AM: Using liquid-c 4.0.0
1:40:39 AM: Using jekyll-sass-converter 2.1.0
1:40:39 AM: Using listen 3.4.1
1:40:39 AM: Using kramdown-parser-gfm 1.1.0
1:40:39 AM: Using jekyll-watch 2.2.1
1:40:39 AM: Installing i18n 1.8.9
1:40:39 AM: Using jekyll 4.2.0
1:40:39 AM: Using jekyll-menus 0.6.1
1:40:39 AM: Bundle complete! 3 Gemfile dependencies, 30 gems now installed.
1:40:39 AM: Bundled gems are installed into /opt/build/cache/bundle
1:40:39 AM: Gem bundle installed
1:40:39 AM: Started restoring cached node modules
1:40:39 AM: Finished restoring cached node modules
1:40:39 AM: Started restoring cached yarn cache
1:40:39 AM: Finished restoring cached yarn cache
1:40:40 AM: Installing NPM modules using Yarn version 1.17.0
1:40:41 AM: yarn install v1.17.0
1:40:41 AM: [1/4] Resolving packages…
1:40:43 AM: warning netlify-cms > netlify-cms-app > netlify-cms-widget-markdown > slate-react > memoize-one@4.1.0: New custom equality api does not play well with all equality helpers. Please use v5.x
1:40:43 AM: warning netlify-cms > netlify-cms-app > netlify-cms-widget-markdown > unified > @types/vfile > @types/vfile-message@2.0.0: This is a stub types definition. vfile-message provides its own type definitions, so you do not need this installed.
1:40:44 AM: warning sp-request > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
1:40:44 AM: warning sp-request > node-sp-auth > request@2.88.2: request has been deprecated, see Request’s Past, Present and Future · Issue #3142 · request/request · GitHub
1:40:44 AM: warning sp-request > request-promise@4.2.6: request-promise has been deprecated because it extends the now deprecated request package, see Request’s Past, Present and Future · Issue #3142 · request/request · GitHub
1:40:44 AM: warning sp-request > node-sp-auth > request-promise@4.2.6: request-promise has been deprecated because it extends the now deprecated request package, see Request’s Past, Present and Future · Issue #3142 · request/request · GitHub
1:40:44 AM: warning sp-request > node-sp-auth > node-ntlm-client > request@2.88.2: request has been deprecated, see Request’s Past, Present and Future · Issue #3142 · request/request · GitHub
1:40:44 AM: warning sp-request > @types/request > @types/form-data@2.5.0: This is a stub types definition. form-data provides its own type definitions, so you do not need this installed.
1:40:44 AM: warning sp-request > request > har-validator@5.1.5: this library is no longer supported
1:40:45 AM: [2/4] Fetching packages…
1:41:07 AM: error copy-text-to-clipboard@3.0.0: The engine “node” is incompatible with this module. Expected version “>=12”. Got “10.23.3”
1:41:07 AM: error Found incompatible module.
1:41:07 AM: info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
1:41:07 AM: Error during Yarn install
1:41:07 AM: Build was terminated: Build script returned non-zero exit code: 1
1:41:07 AM: Failing build: Failed to build site
1:41:07 AM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1
1:41:07 AM: Finished processing build request in 1m20.66738082s

Hiya, sorry you are having trouble with your build.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

thank you, will do so.

best wishes,

Set an environment variable in Netlify UI with name NODE_VERSION and value as 12

Thanks. @hrishikesh. It really helped and it worked. Many thanks!!!

Kindly advise me on the below as well. Unable to build the website.

$ cloudcannon files pull

Removing 108 files… edonee

Updating 10 files… edoneeUsing jekyll compiler

$ cloudcannon cache pull bundle Calculating hash… not found

$ cloudcannon run build Preparing HTML files… edoneeee

$ cloudcannon jekyll parse Reading /_config.yml… edonee

Checking cloudcannon-jekyll… injecting plugin for ruby v2.5.5… edonee

$ export JEKYLL_ENV=production

$ ruby -v (No ruby version specified) ruby 2.5.5p157 (2019-03-15 revision 67260) [x86_64-linux]

$ bundle version Bundler version 2.2.9 (2021-02-08 commit 30e740c073)

$ bundle config --global jobs 4 Configured concurrent installs!

$ bundle config build.nokogiri --use-system-libraries Configured nokogiri flag!

$ bundle config set path /usr/local/__bundle

$ bundle install Fetching gem metadata from https://rubygems.org/ . . . . . . . . . .

Resolving dependencies… Using public_suffix 4.0.6 Using bundler 2.2.9Using colorator 1.1.0Using concurrent-ruby 1.1.8 Using eventmachine 1.2.7 Using http_parser.rb 0.6.0 Using ffi 1.14.2Using forwardable-extended 2.6.0Using htmlentities 4.3.4 Using rb-fsevent 0.10.4 Using rexml 3.2.4Using liquid 4.0.3 Using mercenary 0.3.6 Using rouge 3.26.0Using safe_yaml 1.0.5 Using jekyll-pwa-plugin 5.1.5 Using i18n 0.9.5Using kramdown 2.3.0 Using pathutil 0.16.2 Using em-websocket 0.5.2 Using addressable 2.7.0 Using kramdown-parser-gfm 1.1.0 Using rb-inotify 0.10.1 Using sass-listen 4.0.0 Using listen 3.4.1 Using sass 3.7.4 Using jekyll-watch 2.2.1 Using jekyll-sass-converter 1.5.2 Using jekyll 3.9.0 Using jekyll-include-cache 0.2.1 Using jekyll-sitemap 1.4.0Using jekyll_pages_api 0.1.6 Using jekyll_pages_api_search 0.5.0 Bundle complete! 7 Gemfile dependencies, 33 gems now installed.

Bundled gems are installed into /usr/local/__bundle

$ bundle clean All clean!

$ bundle exec jekyll build Configuration file: vestal-boombox.cloudvent.net/src/_config.yml

Source: vestal-boombox.cloudvent.net/src Destination: vestal-boombox.cloudvent.net/compiled/ Incremental build: disabled. Enable with --incremental

Generating…

jekyll_pages_api_search: checking for Node.js: v10.23.3

jekyll 3.9.0 | Error: undefined local variable or method `page’ for Jekyll:Module

:x: Your build failed, make an update and try again.

While I don’t have any experience with Jekyll, if you can provide the link to your repo, I can try to have a look at what’s happening.

@hrishikesh I appreciate your response and prompt support. Thanks!!