Home
Support Forums

Site built & deployed but app not showing (Page Not Found)

Hi, I’ve successfully deployed a few sites previously but is encountering some problem with the current one at https://dexterous.netlify.app.

The output on the local host (using npm run build and yarn start):

I’ve input the environmental variables in Netlify, and removed the yarn-lock (which I was advised before may interfere with the build/deploy).

The codes are host at https://github.com/markvelous/dex

Appreciate your advice on how I can publish the app on Netlify.

Hi @markvelous

Have you looked at [Support Guide] I’ve deployed my site but I still see "Page not found”?

Looking at you git repository, I see there is no build script. You might find [Support Guide] Can I run a web server, HTTP listener, and/or database at Netlify? useful too.

Hi @coelmay

Thanks for your advice. I’ve gone through those links earlier but they do not seem to point to the solution that I need. But I will continue to read the threads to see if it’s buried in there somewhere.

As for the missing build scripts, I have managed to build one earlier project using Netlify without the scripts (see https://markobots.netlify.app/). I just need to be able to execute npm run start to launch the app but unable to do it at the deploy stage.

Have you tried downloading the deployed files? Is there an index.html in it?

Yes. BTW, this is a CRA. Also, the same setting (npm run start / build) does not work now. The deployment has failed at the build.command.

Hi @markvelous,

If you check your build log, you can find this:

Failed to compile.

/src/components/Swap.tsx
Attempted import error: 'ethers' does not contain a default export (imported as 'ethers').

The answer to which is here:

In your /src/components/Swap.tsx , you need to change

import ethers from "ethers";

to

import { ethers } from "ethers";
1 Like

Brilliant! That fixed it: https://6131d4c5b07abc0007767254--dexterous.netlify.app/

Thanks @hrishikesh !

@coelmay , thanks for jumping in to offer your advice!