Since ive added external domain I get security issues on website visit

Ever since I connected an external domain to my website here on netlify, i often get error codes like this upon visit: NET::ERR_CERT_COMMON_NAME_INVALID.

Is this a common problem when hosting website on netlify and having other company provide domain?
What can I do to get this to stop happening?

Sincerely //

Hi there, glad you found us :wave: before we can help you, we need a little more information on the issues you are facing.

Please tell us:

Hey! Thanks for respons!

Ok, so the domain is:, ive added a txt so that the original is forwarded to the accurate domain.

So the first thing i did was to change the nameservers as requested by netlify. I also requested netlfiy to provide the ssl certificate. I waited a day and everything was working.

The problem is that sometimes the problem explained above still occurs. When i go to the webpage today, it works fine. Yersterday evening when i tried to enter, the error code written above showed. It seems like the ssl comes and goes. This has happened every second day since i changed the domain.


Could i please get help with this. The site has been mostly down for the last week

Hi, @jepza. I’m showing that this domain is using two sets of DNS servers: one controlled by Netlify and the other set at the domain registrar.

This is why it works sometime and doesn’t others. Depending on which name server responds, you get two different websites.

Here is what I see when I test the NS (name server) records for this domain:

;; Received 656 bytes from in 17 ms		3600	IN	NS		3600	IN	NS		3600	IN	NS		3600	IN	NS		3600	IN	NS		3600	IN	NS

The solution for this is to contact your domain registrar and remove the two NS records above and leave only the set of records.

This must be done at the domain registrar (not at Netlify) so please contact their support team and/or documentation if there are questions about how to do that there. If you tell us the name of the registrar, we’ll also do our best to locate their documentation on this subject.

1 Like

Thank you! Ive changed it at the domain and it seems like the problem is solved. Thanks!