Server can't find : NXDOMAIN

I configured my domain - added Netlify nameservers and have already contacted the provider and confirmed that name server propagation is complete. Hence, I should be able to access my deployments via my custom domain that I configured. But when I try to access it - I get this error Server can't find : NXDOMAIN

I have added Netlify’s DNS servers, issued a SSL certificate and enabled HTTPS too. I am able to access my deployments through netlify’s subdomains for my project but cannot access them through my domains and subdomains. I have three deployments that are using the domain and none of them can be accessed via the domain except for netlify’s default subdomains assigned for the deploy. Please help!! It’s been more than 24 hours now and I have already tried twice. It should never take this long!

Hi Rishi,

Site works well for me and I don’t get any NXDOMAIN errors from my browser or tools like dig.

DNS changes frequently take time (days sometimes) to finish propagating, and I think that is likely what has happened with your hostname as DNS config is perfect at the moment as far as I can tell, and this tool which looks from all over the world sees good results too:

If you’re still having trouble, could you let me know what the output of nslookup is from a command prompt on your computer, and if you see the problem on other devices like your mobile phone as well?

1 Like

that is what nslookup is returning. that the servers can’t find domain. Here is the exact error:

** server can't find NXDOMAIN

I have already checked with the domain providers and looks like everything is fine from their side. Even netlify shows me that netlify DNS is being used which is what makes this confusing. I understand DNS propagation might take time but I have already done two attempts. First of which I waited ~ 24 hours and then tried again last night. It still looks like it is failing.

I’ve tried checking through nslookup and curl from 2 different systems on different networks - just to be sure.

And I have already tried out various websites to check if my website is up ( including the one that you sent ) but it is still not resolving through nslookup or curl. Additionally, dig also returns refused for me. Even with +trace option which should have bypassed the cache?

Incase you need, here is the list of some of the websites I have checked it through :

Hi Rishi,

That error message indicates to me some configuration problem - DNS would never use a URL as is shown in your error message:

Server can't find : NXDOMAIN

Anyway, as I said yesterday when I answered you, your site is working great for me and thus for most of the rest of the internet. I suspect a local configuration problem.

You didn’t answer my questions about whether it works for you from another computer or network, or what nslookup says from your computer, which will be required for us to debug further.

You would have had an answer right now if you’d given me the answers I asked for to help troubleshoot :wink:

Hi. I have already answered those in my previous answer. I have tried it in two different systems with nslookup, curl and dig and none of them resolve. dig returns the status refused for the query, so does curl. and I’ve already mentioned about nslookup’s output in my post and in the answer. And I’ve also tried it on different networks as stated in my previous reply.

Seems like a local DNS cache issue to me. Will try checking after moving to google’s public dns and giving it a shot. If it works then I’ll post another reply here so that if there’s any other community member who looks up for it later will find some answers. Thx

thanks for keeping us updated @rishichawda! Sorry you are having a hard time getting this working :confused:

Looks like everything was fine. Just a dns cache issue like I suspected. dig and nslookup resolve now along with curl sending me appropriate pages.

1 Like

fantastic, glad it worked out.