Secure Connection Can Not Be Established

I received the following error at the end of November. I have since tried to renew manually several times (spaced out over weeks), but to no avail. My site is currently down with the message that a secure connection can not be established. Everything was running fine until November. No changes were made to the site, DNS, etc.

Any help would be appreciated.

Failed to renew TLS certificate for

The TLS certificate for will expire on Nov 27, 2019. We tried to renew it, but got this error message:

Acme::Client::Error::ServerInternal: Error finalizing order

We’ll keep trying — in most cases of failure, we succeed on the next attempt. However, it’s still a good idea to check the certificate status in your site’s SSL/TLS settings.

I see what you were seeing. Not sure what happened to the certificate (it looked valid in our database), but I removed and recreated it and it seems to be working now.

In the future you may be able to simulate what I did by adding an additional “dummy” hostname to the site ( which will trigger a renewal (there is no other way for you to trigger a renewal unless we are close to expiration date).

Let me know if things aren’t working better now, please!

Thanks so much for the quick response and solution! I will keep the tip above in mind should something like this happen again. For clarity on the tip, the dummy host name would be added under the domains section as ‘Add Domain Alias’?

yup, that is correct!