Scully Build Does Not Finish

I’m trying to convert my personal site ( or to Angular/Scully from Jekyll. I have it all working on my local machine, but when I try to do a branch deploy to test, the build doesn’t finish. The Angular app builds, and Scully starts doing its work, but it stops after discovering all the routes.

I am using a netlify.toml file to determine the build steps for the branch deploy, in which I set the NODE_VERSION to 12 (which is required for Scully to build properly).

    command = 'ng build --prod && npm run scully -- --scanRoutes'
    publish = 'dist/static'
    environment = { NODE_VERSION = '12.18.3' }
    NODE_VERSION = '12.18.3'

From everything I can tell, this should work. If anyone has any ideas, that’d be great. Thanks!

hiya! Looks like you are close to getting a success here - but it seems from the build log that your site is taking too long to build (the default max runtime is 15 minutes)

Two things i am immediately thinking of - is this a large site? Or is it possible that there is a lingering background process that never terminates?

We can make some changes to give you a longer runtime, but if the problem really is that you have some lagging process, it would be better to optimize that first.

Some more info:

So the site isn’t that big. Maybe 6 pages and then 30 blog posts or so? Maybe 40? It’s not that big. So that shouldn’t be the issue.

It could be a process never ends, but I just can’t see enough from the output in Netlify to know. I have the Scully team looking at it as well so they might be able to come up with something.

Hi, @pjlamb12, this very much appears to match the issue being discussed in this support guide:

To summarize, there is a background process not existing and this prevents the build from ever finishing. Making sure that all database and HTTP connections are closed when no longer needed is the usual solution for these types of issues.

If there are other questions not answered by that support guide, please let us know.

I’m definitely not running a watch command or something like that. The command is npm run scully, which doesn’t start a watch command or anything. It never even gets to the point where it starts generating the pages is the thing that’s weird. It says it’s finding the routes, creates the routes list file, and then stops. There’s no hints as to what is going on.

On my local computer, the process takes a couple minutes to build the Angular app and then run the scully command. I’m at a loss as to what the issue could be.

hey there, sorry that this continues to be a bit of a frustrating experience!

We’re not sure exactly what the problem might be - but one thing i might try if i were you is to reach out to the folks at scully:

And see if they have some ideas on what might be causing the problem?

We don’t get too many Scully questions here, but it does seem like people have made Scully projects work on netlify in the past:

We’ll keep thinking on it - but do please update here if you make any progress or get any helpful information on why its not working.

I’ve done some research into this. I created a new Scully site ( with a whole bunch of fake blog posts. I pushed it to a new repo and set it up to deploy on Netlify. It worked just fine. I copied over the app files from the first site ( into the new Scully site. It built and deployed just fine on Netlify.

Then I copied all the files from a brand new Scully site into the repo that was not finishing building. I pushed that code (which built on the site) and pushed it. The build hangs.

I just created a new site from Git in Netlify, and pointed it to the rewrite branch in my original repository. I deployed from that branch instead of master, and the deploy worked. There’s nothing wrong with the app or anything. Something is wrong in the original Netlify app/deployment when doing a branch deploy instead of from the master branch.

There’s something about doing a branch deploy on that is not working. I can’t figure it out. But I don’t want to deploy it to production until I know that everything is working like it’s supposed to.

Heya @pjlamb12 and thanks for sticking with us! I see some successful branch builds in your build list since you last wrote, so maybe you figured out the situation? If so mind sharing what you changed? If not, I think we could get some more information out of your build if you append a new command to your existing one (which I think is set in your toml file):


npm run netlify

…change to:

npm run netlify && ps auxwww && sleep 30

This will:

  1. tell us if npm run netlify ever exits. If this is the case, and that isn’t what you expect, next steps are to run locally and see if you can debug what’s happening:
  2. if it does exit, it will show what is still running (which I think you also don’t expect).

Thanks in advance for your help!

Ugh, I forgot to post this here. the fix was that my site was using an old build image. I think that’s because I created the site like 3 years ago. Once I updated the build image in the site settings, everything worked as expected.