Sapper build no longer crawling site

All of a sudden deployments of my site are returning 404s and looking at the logs it seems the build process is not crawling my static Sapper site to build the pages. I’ve tried rolling back to an prior successful commit but so far to no avail. Everything is as if nothing changed when I run the site locally. It should be crawling the entire site around 7:43:41 below.

Build Settings:
[github.com/j-adom/AlkebuSapperFront]
Base directory — /

Build command — npm run build

Publish directory — /web/sapper/export

Builds — Active

Build Log:

7:43:41 PM: alkebu-sapper: ┌─────────────────────┐
7:43:41 PM: alkebu-sapper: │ built serviceworker │
7:43:41 PM: alkebu-sapper: └─────────────────────┘
7:43:41 PM: alkebu-sapper: > Built in 2m29s
7:43:42 PM: alkebu-sapper: > Crawling http://localhost:3000/
7:43:43 PM: alkebu-sapper: 27.1 kB service-worker-index.html
7:43:47 PM: alkebu-sapper: > Finished in 2m35s. Type npx serve sapper/export to run the app.
7:43:53 PM: lerna success run Ran npm script ‘build’ in 2 packages in 162.1s:
7:43:53 PM: lerna success - sanity-sapper-blog-studio
7:43:53 PM: lerna success - alkebu-sapper
7:43:54 PM: ​
7:43:54 PM: (build.command completed in 2m 42.9s)
7:43:54 PM: ​
7:43:54 PM: ────────────────────────────────────────────────────────────────
7:43:54 PM: 2. Deploy site
7:43:54 PM: ────────────────────────────────────────────────────────────────
7:43:54 PM: ​
7:43:54 PM: Starting to deploy site from ‘web/sapper/export’
7:43:54 PM: Creating deploy tree
7:43:54 PM: Creating deploy upload records
7:43:54 PM: 56 new files to upload
7:43:54 PM: 0 new functions to upload
7:43:56 PM: Starting post processing
7:43:56 PM: Post processing - HTML
7:43:56 PM: Post processing - header rules
7:43:56 PM: Post processing - redirect rules
7:43:56 PM: Post processing done
7:43:57 PM: Site is live :sparkles:
7:43:58 PM: Finished waiting for live deploy in 2.076723067s
7:43:58 PM: Site deploy was successfully initiated
7:43:58 PM: ​
7:43:58 PM: (Deploy site completed in 4.4s)
7:43:58 PM: ​
7:43:58 PM: ────────────────────────────────────────────────────────────────

Hey there, @j-adom :wave:

It looks like this thread has been quiet for the past week. Are you still experiencing this issue? If so, can you share what additional troubleshooting steps you have taken? Additionally, can you share your site ID?

Thanks!

I never found the problem. Rebuilding my app and pushing it up using netlify dev from Nodejs locally got my site back online but if I redeploy the same build on netlify.app it still doesn’t work.

Thanks for letting me know. Can you share your site ID as well as your build logs from your most recent attempt? Having a site ID will help us look into things further on our end :slight_smile: