Root relative pages (custom domain) throw page not found

Hey guys,

Hope you’re safe and well. I’m struggling with an issue on root relative pages on is accessible in India but not in US. is the domain name mapped to doesn’t work in India or in US. It throws a page not found error.

Domain name is registered with namecheap. I don’t see any settings on netlify relevant to root relative pages.

I’m not sure if the issue is with netlify or with namecheap.

Could you please help me fix this? Does this have anything to do with cache invalidation?


hmm interesting!

is this relevant at all?

I don’t think it’s an issue with redirects on an SPA; especially because the about url seems to work fine on the naked url from netlify.

Are you able to see the about page from accessing the netlify url?

Do you think I’m missing any a records in the dns settings on namecheap?

Sunil, i think something tricky is going on with routing on your site that has something to do with your SSG/app routing.

Last week we migrated all of our customers non-custom domains from .com to .app and it seems like this is somehow not playing nice with your site.

when i pull up your root domain: i see it being redirected to, and then is accessible to me :tada:

but when i click directly on, i got a 404 once and now I am seeing the correct page. works for me, does not work.

Is there a possibility that is somehow pointing to the .app domain?

It used to be pointed to .com domain. I changed it to .app to see if that works. In either case, about page still doesn’t seem to work on directly works for me but shows a blank page.

hey sunil, it’s working fine for me actually - redirects as it should.

is this possibly a local caching issue? Have you tried in an incognito window? :thinking:

Hey Perry, thanks for looking into this again.

Yes, I’ve tried incognito and multiple browsers infact. What I need is to work.

So far, I’ve been unsuccessful in getting it working with a .com or .app netlify url pointed to

Would you like me to share a screenshot of the dns settings/records?

For what it’s worth, loads for me, albeit without SSL. I’m in Southern California.

However, you have two A records in your DNS, one for NameCheap and one for Netlify. You should probably delete the one for NameCheap…

As you already have a CNAME set up for www that points to Netlify, you should also consider switching your primary domain from the apex to the subdomain for better CDN performance.

1 Like

@gregraven, thanks for the detailed note. Good to know you’re able to access the about page from southern california.

Unfortunately, I’ve asked around and they still can’t access the page. What could be the reason that it’s accessible for some and not others?

This is currently what I have on namecheap -

I previously hosted the site on google cloud platform and didn’t have any issues with internal links. It’s quite strange that there’s no reliability that root relative pages can be accessed regardless of geolocation.

I would delete that URL redirect to and replace it with an A record for @ pointing at Netlify’s load balancer IP address, which I believe is

@gregraven deleted the redirect. A record is also in place.

I’ve tested at different locations and still no luck :frowning:

@perry, are you able to access the about page?

@Sunil FWIW, your site loads for me in Southern California over http only. Your name servers are very poorly propagated. Your “about” page no longer loads for me.

I see that you are using I recognize as being NameCheap servers, but I’m not familiar with This may have nothing to do with it, though, and you may have no control over it.

Unless you have a compelling reason not to, it seems that you would have better results using Netlify DNS. My two cents.

Hey @Sunil,

I’ve checked across our CDN and there’s no reason why the site would be displaying different data around the world.

As you’re not using Netlify DNS, at your registrar, you only need to configure the 4 name servers.

To echo @gregraven, you could use Netlify DNS which simplifies this step.

A single-page app will only need one redirect rule too: /* /index.html 200

Once this is complete, we can home in on the issue :+1: