Reverting my git repository to that of the last successful build fails

Dear community

I started off with a starter from Stackbit which worked fine.

When I tried to create my own Gatsby component, I ran into an error during build. I decided to revert the commit of my git repository, but I keep hitting the same error.

Which makes me confused, as I don’t know what can be different from my original build The code on my git repository is identical to that which deployed successfuly.

Netlify instance:

Hi Shane,

One thing you can try that is easy is retrying the deploy without cache. Sometimes the cache gets a bit bogus and clearing it can help.

If it’s not something like that, I’d be comparing the git commits to see what the changes were in your code - I bet there is one that you didn’t see by manually looking, perhaps :slight_smile:

Thanks so much for your reply.

I forgot that even though the code was equal, my structured content in Sanity was not.

thank you for sharing your solution! This is definitely helpful for other users :+1: