Home
Support Forums

Resources returned blank

Hi,

I have updated my website and for the first time I got resource over network but they seemed either broken or empty. I have uploaded bunch of webp images and Netlify CDN returns something but it is not an image:
Warhammer Underworlds Database and Deck Builder. and somehow only portion of the uploaded today images are broken.

Cheers!

Hi @fxdxPZ,

I’m having a little trouble understanding your problem. Could you please explain in a little more detail?

HI,

Sorry for confusing description.

I have a React app hosted on Netlify. I have uploaded bunch of images to be used within app, in png and webp formats. Most newly added images are fine, but somehow group of them when returned have this similar to the following response header:

age: 0
cache-control: public,max-age=604800
content-encoding: br
content-length: 564
content-type: text/html; charset=UTF-8
date: Thu, 21 Oct 2021 11:15:44 GMT
etag: "caaffc3f0281d2e2c6a65aa736baa2f2-ssl-df"
server: Netlify
vary: Accept-Encoding
x-nf-request-id: 01FJH90RVD5XWG6625A8QW6XVD

but same file in incognito mode has following response header:

accept-ranges: bytes
age: 0
cache-control: public,max-age=604800
content-length: 18926
content-type: image/webp
date: Wed, 27 Oct 2021 21:04:28 GMT
etag: "163b69db036bcd4099fd0433a943c34b-ssl"
server: Netlify
strict-transport-security: max-age=31536000
x-nf-request-id: 01FK1S337A1AC9W80J3G1ZG28J

Hard reloading page doesn’t help. So it feels like those images somehow cached, but I wonder why response header is different in icognito mode or in some other browser.

And I suspect that if they fail for me they might fail at least to some other users.

This is common in React apps because you need to use /* /index.html 200 rewrite rule. Because of this rule all files that do not exist are routed to your index.html page which returns the text/html as content-type header.

About that request ID with error, I’m unable to locate it in our logs.