Replacing Gridsome with Nuxt 3, site won't build, wrong node version?

My site is:

Hi! I’m moving my site from Gridsome (rip) to Nuxt 3. No matter what I try, I haven’t been able to get my Nuxt site to build. Because I couldn’t get my branch to build, I created another test site in Netlify and it builds fine. I used the default settings npm run build and dist.

That test site is:

I merged the nuxt3 branch into master, but my won’t build. It’s like it’s using an old server or something. On the test site that works, the node version is v16.19.0 and on it looks like it’s trying to build with v12.18.0. Could that be part of the issue?

What I tried:

  • I updated the build settings to npm run build and dist
  • I removed env variables I didn’t need anymore.
  • I’ve triggered deploys with clearing the cache
  • I checked and both sites Build Images are Ubuntu Focal 20.04 (default)

The logs on the builds for the two sites are very different, which seems to me that there is something hidden I cannot see to change. Any help would be very appreciated!

Link to the repository:

Please let me know if you need anything else! Thank you in advance. I got laid off last week and I’m pushing hard to these changes live on the web. :pray:

I fixed it. The issue was the older site was still using node v12 and nuxt 3 requires v16+
I set NODE_VERSION to v16.19.0 and the site built correctly.

One more question: will minor updates still be installed if I explicitly set the node version like this?

1 Like

Hi @bksiefert :wave:t6: ,

Welcome to the forums! :netliconfetti: Thank you for coming back and letting us know that you were able to solve your issue and the solution. This will help others who stumble upon your post! Good luck and happy building! :rocket: