Repair https certificate for two domains

PLEASE help me repairing the HTTPS settings for my domains: – works just fine – is not secure

I clicked on renew some hours ago, but the domain is just not added to the HTTPS so I read to ask here for you to repair it and I did.

Thank you : )

The problem is because your apex domain is not pointing to Netlify:

dig A +short

That’s not the correct IP Address. The correct one is listed here: Configure external DNS for a custom domain | Netlify Docs.

TL;DR: It’s

Thank you, that makes total sense. I thought the latest A record would overwrite old ones. Turns out it doesn’t. I have updated it now and I’m hoping it will work in a few hours. Thanks for your help

1 Like

Thanks for letting us know, @simonfreund! Should this not resolve itself now that you have updated it, please follow up here!

Thank you, Hillary. This solved the issue and everything is working just fine now : )

Dear @hillary – sorry to bother you again. I tried adding aliases ( and this kind of broke the whole thing and now is nor working anymore. I deleted the alisases ( & but I can’t rewnew the certificate… Your help is much appreciated. Thank you, Simon

Hey @simonfreund

I see is working and redirecting to with a valid SSL certificate.

I do see an AAAA record that isn’t a Netlify address that may cause issues

dig AAAA	86254	IN	AAAA	2a03:4000:30:cc36::15:3091

Can confirm, @simonfreund , that what Coel describes would absolutely block us from renewing your certificate. If you can remove that AAAA record I think everything will work as you expect.

Thank you so much for looking into this @coelmay & @fool – I have now deleted that AAAA record, hoping the issue will be solved that way. Is there anything else I have to do? Rewnew the certificate once again, for example? THANK YOU – so glad to have your help, I’m just so lost with all of those records : )

As mentioned in my last post @simonfreund, your site is loading with SSL enabled, so there is no need to renew the certificate.

1 Like