Removing custom domain fails with 502 error

We’re running into a 502 error while attempting to remove custom domains (pictured below). This occurs when trying to edit custom domains as well. Our site name is What gives?

1 Like

I am also seeing a 502 error when I try to add an MX domain :frowning:

1 Like

I’m also having this issue.

Hi @root,

This happens because you’ve too many domain aliases. The API times out on processing those. For your use case, I’d recommend using wildcard domain.

Anyways, I’ve removed the domain from our end.

@Anjum48 and @bubbo, we’d need more details than those statements, unfortunately :slight_smile:

I retried last night and the issue disappeared and I was able to set up my servers. It must have been something temporary

I have a 100 domain limit on my subdomains, and I only have 60 currently, so not sure its that (I’m also getting the same error)


A fix has been implemented, could you let us know if you’re still having issues?

Hello. I have a similar problem i added a domain couple of weeks ago, It worked fine. I then removed and today i tried adding the domain back but i keep getting a 502 error the domain is from godaddy. Please help, thank you.

Hi @bogdan12893 ,

It looks like you were able to self-resolve the issue as I see the custom domain has been added to the site. Let us know if you still need help!