Home
Support Forums

Redirect to another website not working

Hi,

I have a website hosted on Netlify that I want to redirect to another website. I’ve created a _redirects file that looks like this:

/*    https://create.weavly.org

The website is “c2lc-build” and the repository is GitHub - codelearncreate/c2lc-coding-environment

In the deploy logs, I can see the redirect is picked up by Netlify but the redirect is not happening when we access the website at https://build.codelearncreate.org.

It’s probably something very obvious but I can’t see it. Could anyone help?

Thank you!

Hey there, @gtirloni

Thanks for reaching out. A good first stop for any redirects debugging is this Support Guide:

Take a look and work through some of those suggestions. If those don’t work, let us know and we can look into this further.

Thanks but it still doesn’t work.

1 - The file is processed and ends up in the deployment (I can see it in the zipfile)
2 - The deploy logs show it processed 1 rewrite rule (which is all that exist)

However, reaching the root of the website doesn’t redirect. If I reach “/abc” then it redirects, but I need anyone going directly to the website to be redirected.

You might need to force the redirect @gtirloni.

For a permanent redirect

/*    https://create.weavly.org    301!

For a temporary redirect

/*    https://create.weavly.org    302!

These are forced through the use of `!`

Forcing worked! Thank you <3