Home
Support Forums

Redirect error on Google Search console for non-https bare URL

I’ve got 3 sites that have all had Search Console redirect errors appear in the last week, none of which had any issue previously.

In all cases, the redirect error is on redirects from http://www.[domain-name] to https://[domain-name]

Any kind of information about a timescale for a resolution and anything that can be done to bump the priority of the issue would be great - seeing that this thread has been going for weeks now is making me wonder whether I need to be looking for an alternative to Netlify.

3 Likes

I’m also waiting urgently for a fix. I have a new site that isn’t being indexed properly from the start due to these redirects, and at some point I’ll have to decide whether it needs another solution if the problem remains.

2 Likes

Hi, @Ultra, @eduardo.hosoume, @coelmay, @gregraven, @etiennedesportes, @pduchnovsky, @cfcurtis , @Joe1, @joeellis, @heyman, @jonasva, @gavinhenderson, @cam, @gideongoddard, @dhewi, and anyone else that reads this topic.

This issue is resolved now. ​Please let us know if you see any instances of this redirect loop happening again (as it should no longer be occurring).

6 Likes

This is great news. Thank you @luke and the rest of the team.

2 Likes

All looks good. Thanks so much :grin: :thank_you:

2 Likes

Unfortunately this did not solve my issue. However! I went through my netlify settings to see if there might be anything weird. Turns out I had netlify prerendering enabled, so I disabled it and deployed and now the bots are happy.

I see that prerendering is a beta feature, can I report this as a bug somewhere?

Hi, @cfcurtis. There was a bug at Netlify but it was fixed. If the issue you are seeing is not fixed and it only happened with prerendering enabled then it is quite possible that the issue is being caused by client side javascript (which would not be Netlify’s bug to fix as we don’t write your site’s javascript).

Before we can file a bug for this, we need to provide instructions to reproduce the issue happening or otherwise provide documentation of the issue. Would you be willing to enable prerendering on a site where the issue can be seen for testing?

It’s definitely possible it’s on my side, especially as it seems to be a different error than others are encountering. I re-enabled prerendering on my site, and I can live without searchability for a little longer.

Steps to reproduce:

  • Visit https://www.pdfstitcher.org with a bot user agent, such as Googlebot or LinkedInBot (e.g. curl -svo /dev/null -A Googlebot https://www.pdfstitcher.org
  • Response is 504 gateway timeout
  • Response without user agent override is 200
  • Response when connecting directly to netlify subdomain is also 200 (curl -svo /dev/null -A Googlebot https://brave-volhard-5d9df5.netlify.app)
  • Github repo is public at GitHub - cfcurtis/pdfstitcher-org: Website for pdfstitcher

I apologise if it is a problem on my end, I’m new to web development and have mostly just modified a template so far. The part where it works on the netlify subdomain but not my custom domain is really confusing to me.

I just tested your site with the prerendering service run locally and I do see that your site does timeout (returning a 504) with our prerender.

I don’t any insight into what your site does so I don’t know why it is timing out. You might be able to debug this by testing it yourself. The instructions to do this can be found here:

Note, deleting the line with server.use(prerender.basicAuth()); in server.js is typically required to get the service running locally.

This other forum topic might be helpful as well:

To summarize, your issue is not related to the other issues above and is instead a timeout of the prerendering service due to something specific about your site.

If there are other questions please let us know.

Thank you for looking in to this, I will disable prerendering for now and investigate locally. I thought it couldn’t be a local problem because it worked with the netlify subdomain but not my custom domain, but evidently I have a lot to learn.

1 Like

Hi Luke, it doesn’t look to be resolved on my end. Is there anything else I need to do, aside from requesting another validation from Google?

Hi, @Duo-Studio. We can take a look to see if it is the same issue or not. If it is the same issue (meaning this bug isn’t actually fixed) we will reopen the issue and get it developer attention.

To do this, I need to confirm what is happening. Would you please send us the URL which isn’t redirecting correctly?

You can post that information publicly or you can private message (PM) that to one of our support staff. I’ve confirmed that PMs are enabled for your community login. Please keep in mind that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

@Duo-Studio, would you please also confirm if you are seeing a redirect loop or a 504 status issue?

I also want to clarify that, while @cfcurtis was seeing an issue with the prerendering service returning a 504 response for their site, it wasn’t the same issue as the redirect loop originally being reported. (We try to keep topics (aka “posts”) limited to a single topic (yes, I said we keep “topics to a single topic”.)

@cfcurtis if you do want to troubleshoot the 504 issue further, would you please create a new topic for that? We are happy to assist with additional troubleshooting (or maybe a Netlify Pilot or other forum member will assist). We just want to keep each issue being discussed in its own topic.

Hi, @Duo-Studio. I got the PM information from you. I’m replacing the real apex domain with example.com. Whenever I write example.com just replace that with the real apex domain you sent me.

The information you send doesn’t show a redirect loop. It shows a 301 redirect from https://www.example.com/ to the primary custom domain of https://example.com/ which returns a 200 response. That isn’t a redirect loop. That is one redirect and a 200 status. There is no loop at all.

I thought maybe you were seeing the redirect look in some other way but nothing I tested triggered any looping behavior (using HTTP only, starting at the apex, using a prerender user-agent - nothing I tried would trigger a loop).

Would you please confirm the loop that you are seeing? Again, you can PM that or post it here using example.com and we can replace that with the real apex domain when testing.

1 Like

Hi, @Duo-Studio. I’ve gotten another PM from you. I must be clear that we don’t do troubleshooting in private on this forum.

The screenshots you included do not show any information about a redirect loop. There is text which reads “redirect error” but that isn’t enough information to troubleshoot this.

I’m not personally able to trigger a redirect loop or error in any way. To troubleshoot this I need some way to see an issue occurring. Do you have instructions to explain how we can see an error?

@daveseth9682 Welcome to the Netlify community? What makes you think this is a Netlify issue? Your site seems not to be hosted on Netlify.

|====================== get x-nf-request-id =====================
| -------------------- blank if not Netlify ---------------------
| ---------------------- couponsagent.com ----------------------
| ---------------------------- http -----------------------------
| ---------------------------- https ----------------------------
| -------------------- www.couponsagent.com --------------------
| ---------------------------- http -----------------------------
| ---------------------------- https ----------------------------
|================================================================
2 Likes

@luke

I wish I knew where the error is coming from too. The site was running fine without the error until May 29.

In your opinion, what would be the best way to resolve this?

About this, @Duo-Studio :

I can only answer if I can see the issue occurring.

In the other examples in this topic, people were able to explain to me what triggered the redirect loop. I was then able to follow those instructions to see the redirect error happening myself.

This allowed us to find a bug at Netlify and we got that fixed. No one is reporting further issues since that bug was fixed.

If you are still seeing issues, we would be happy to examine it to find out why. It could be because of a misconfiguration of some kind in the site’s code. It could be a bug at Netlify. However, the only way to debug what is happening is to be able to identity the HTTP responses which are incorrect or to otherwise reproduce the issue in some way.

The biggest problem I’ve had personally in troubleshooting in this topic is that Google’s software is hiding all kinds of important details for troubleshooting. For example, we send a unique header with every HTTP response, the x-nf-request-id header. This header would tell me exactly which responses Google saw as “wrong” and I could start looking at those responses for clues.

We send this header. Google receives this header. However, Google doesn’t provide you with anyway of getting that information and this means I don’t have any way to troubleshoot.

Again, with the other examples above, we were able to find the issue by someone providing enough information to reproduce the behavior.

Now, I have tried to reproduce this. I have queried all the CDN nodes for your site and cannot trigger a redirect loop. I tested all node with both your apex domain (with is the primary custom domain) and the www subdomain (which redirect to the apex). The apex always returns a 200. The www subdomain always 301 redirects to the apex. This happens both with and without user agents for bots.

In other words, I’ve tried to find evidence of an issue and I cannot. Without additional details, I have no way of researching this further. Also, while unlikely, this could just be a bug at Google.

If there are other questions, please let us know.

Hello I am having this problem for my website marcin-zygan.com and https://www.marcin-zygan.com I checked it with redirect checker and all seems to be ok . But I cannot get my pages indexed at all , I am getting redirect error in Google’s search console and I have no idea how to fix that . Any help much appreciated Thank You

Hi @Souloo,

From my experience, this keeps on happening from time to time and I’d personally consider it normal. Just like you say, everything seems to be okay from our end, but it’s Google that’s seeing the redirects. If there was a way to get better logs about this, it would have been easier to debug,

Thank You for reply . I’ll just wait then , maybe they will index my page some day :grin: