Home
Support Forums

Recent and Historical Form Submissions are empty

Customer called me today letting me know that some of the forms on his website are not working properly. Submissions were showing up empty in Netlify - ip, user_agent and referrer, created_at are the only things visible in the Netlify Forms UI. Other forms are working correctly.

We did a little digging together and we were able to pinned it down to a difference in the redirect url. Forms that were working didn’t include a / on the end of the thank you page URL. In both situations the visitor was correctly redirected to the thank you page after a form submission.

I can see in the Git History that last change we made to the forms was on July 8. We changed the naming of the forms to prepare them for Multilanguage support. With every big change we test everything to make sure it’s working correctly. On July 8 everything worked fine and submissions were coming in like expected.

Because the form name changes - We can also see the old form variants with their submissions in Netlify. But strangely they are also all empty?

I find this all confusing and mostly very annoying for my customer. I have a few questions

  1. Why can something simple like a / on the end of a thank you url, mess up a form submission?
  2. Why were those forms working before? And suddenly stopped working.
  3. Why are historical submission empty in netlify forms ui?

Information
Netlify site: (philandflo.netlify.app)
domain: https://www.philenflo.nl
Git Repo: private (can give access to netlify staff member)

Hey there, @frankspin :wave:

Thanks so much for reaching out. These are great questions!

Hiya, @frankspin

Sorry you are having trouble getting your forms to work! I appreciate how many details you shared above. We will need a few more things in order to dive into this further.

Can you please share the following information with us?

  1. The URL for your live form as you want visitors to use it. I poked around the domain linked above, and it looks like there are a few form submission spaces on the site.
  2. The URL of your deployed html form. In case you have a javascript form, we need to literally be linked to the html version you’ve deployed, as mentioned above (look for “ pure javascript form ”)
  3. The form name that you’ve set and that shows in our UI.
  4. Any errors or logs from the Netlify build logs, dashboard or browser developer console.

Additionally, this Support Guide is the first port of call to debug any forms issues. Have you read through this and tried any of the steps included?

Lastly, do you know when the form stopped working between July 8 and now? Any additional information pinpointing the timeline would be great.

Thanks so much.