React build not working

Trying to get this live: GitHub - lyletilley/ensembletestlyle

And getting this issue:

5:26:46 PM: Build ready to start
5:26:48 PM: build-image version: d2c6dbeac570350a387d832f64bc980dc964ad65 (focal)
5:26:48 PM: build-image tag: v4.8.0
5:26:48 PM: buildbot version: 4aaa27647e859c2d38cfbb25901ceae1e7f3eeae
5:26:48 PM: Building without cache
5:26:48 PM: Starting to prepare the repo for build
5:26:48 PM: No cached dependencies found. Cloning fresh repo
5:26:48 PM: git clone GitHub - lyletilley/ensembletestlyle
5:26:49 PM: Preparing Git Reference refs/heads/main
5:26:49 PM: Parsing package.json dependencies
5:26:50 PM: Starting build script
5:26:50 PM: Installing dependencies
5:26:50 PM: Python version set to 2.7
5:26:51 PM: Downloading and installing node v16.15.0…
5:26:51 PM: Downloading https://nodejs.org/dist/v16.15.0/node-v16.15.0-linux-x64.tar.xz
5:26:51 PM: Computing checksum with sha256sum
5:26:51 PM: Checksums matched!
5:26:54 PM: Now using node v16.15.0 (npm v8.5.5)
5:26:54 PM: Started restoring cached build plugins
5:26:54 PM: Finished restoring cached build plugins
5:26:54 PM: Attempting ruby version 2.7.2, read from environment
5:26:55 PM: Using ruby version 2.7.2
5:26:56 PM: Using PHP version 8.0
5:26:56 PM: No npm workspaces detected
5:26:56 PM: Started restoring cached node modules
5:26:56 PM: Finished restoring cached node modules
5:26:56 PM: Installing NPM modules using NPM version 8.5.5
5:27:07 PM: npm WARN deprecated source-map-resolve@0.6.0: See GitHub - lydell/source-map-resolve: [DEPRECATED] Resolve the source map and/or sources for a generated file.
5:27:15 PM: npm WARN deprecated svgo@1.3.2: This SVGO version is no longer supported. Upgrade to v2.x.x.
5:27:20 PM: added 1419 packages, and audited 1420 packages in 24s
5:27:20 PM: 186 packages are looking for funding
5:27:20 PM: run npm fund for details
5:27:20 PM: 6 high severity vulnerabilities
5:27:20 PM: To address all issues (including breaking changes), run:
5:27:20 PM: npm audit fix --force
5:27:20 PM: Run npm audit for details.
5:27:20 PM: NPM modules installed
5:27:21 PM: Started restoring cached go cache
5:27:21 PM: Finished restoring cached go cache
5:27:21 PM: go version go1.16.5 linux/amd64
5:27:21 PM: go version go1.16.5 linux/amd64
5:27:21 PM: Installing missing commands
5:27:21 PM: Verify run directory
5:27:22 PM: ​
5:27:22 PM: ────────────────────────────────────────────────────────────────
5:27:22 PM: Netlify Build
5:27:22 PM: ────────────────────────────────────────────────────────────────
5:27:22 PM: ​
5:27:22 PM: ❯ Version
5:27:22 PM: @netlify/build 27.1.3
5:27:22 PM: ​
5:27:22 PM: ❯ Flags
5:27:22 PM: baseRelDir: true
5:27:22 PM: buildId: 62967a06a7f203398f511082
5:27:22 PM: deployId: 62967a06a7f203398f511084
5:27:22 PM: ​
5:27:22 PM: ❯ Current directory
5:27:22 PM: /opt/build/repo
5:27:22 PM: ​
5:27:22 PM: ❯ Config file
5:27:22 PM: No config file was defined: using default values.
5:27:22 PM: ​
5:27:22 PM: ❯ Context
5:27:22 PM: production
5:27:22 PM: ​
5:27:22 PM: ────────────────────────────────────────────────────────────────
5:27:22 PM: 1. Build command from Netlify app
5:27:22 PM: ────────────────────────────────────────────────────────────────
5:27:22 PM: ​
5:27:22 PM: $ npm run build
5:27:22 PM: > ensembletest@0.1.0 build
5:27:22 PM: > react-scripts build
5:27:24 PM: Creating an optimized production build…
5:27:31 PM:
5:27:31 PM: Treating warnings as errors because process.env.CI = true.
5:27:31 PM: Most CI servers set it automatically.
5:27:31 PM:
5:27:31 PM: Failed to compile.
5:27:31 PM:
5:27:31 PM: src/App.js
5:27:31 PM: Line 53:16: img elements must have an alt prop, either with meaningful text, or an empty string for decorative images jsx-a11y/alt-text
5:27:31 PM: ​
5:27:31 PM: ────────────────────────────────────────────────────────────────
5:27:31 PM: “build.command” failed
5:27:31 PM: ────────────────────────────────────────────────────────────────
5:27:31 PM: ​
5:27:31 PM: Error message
5:27:31 PM: Command failed with exit code 1: npm run build (Search results for '"non-zero exit code: 1"' - Netlify Support Forums)
5:27:31 PM: ​
5:27:31 PM: Error location
5:27:31 PM: In Build command from Netlify app:
5:27:31 PM: npm run build
5:27:31 PM: ​
5:27:31 PM: Resolved config
5:27:31 PM: build:
5:27:31 PM: command: npm run build
5:27:31 PM: commandOrigin: ui
5:27:31 PM: publish: /opt/build/repo/build
5:27:31 PM: publishOrigin: ui
5:27:32 PM: Caching artifacts
5:27:32 PM: Started saving node modules
5:27:32 PM: Finished saving node modules
5:27:32 PM: Started saving build plugins
5:27:32 PM: Finished saving build plugins
5:27:32 PM: Started saving pip cache
5:27:32 PM: Finished saving pip cache
5:27:32 PM: Started saving emacs cask dependencies
5:27:32 PM: Finished saving emacs cask dependencies
5:27:32 PM: Started saving maven dependencies
5:27:32 PM: Finished saving maven dependencies
5:27:32 PM: Started saving boot dependencies
5:27:32 PM: Finished saving boot dependencies
5:27:32 PM: Started saving rust rustup cache
5:27:32 PM: Finished saving rust rustup cache
5:27:32 PM: Started saving go dependencies
5:27:32 PM: Finished saving go dependencies
5:27:33 PM: Build failed due to a user error: Build script returned non-zero exit code: 2
5:27:33 PM: Creating deploy upload records
5:27:33 PM: Failing build: Failed to build site
5:27:33 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 2 (Search results for '"non-zero exit code: 2"' - Netlify Support Forums)
5:27:33 PM: Finished processing build request in 45.564410498s

Can anyone help ? Thanks

hi there, you need to either:

1.) fix the warning regarding alt text that is shown above (best solution)
2.) skip over the warning and proceed to building anyway, here is how (not recommended)