Re deploy of a commit that worked before now exists with error 127


On APril 6, I deployed a commit 44c4e05 and the build worked

Today I made some changes and pushed them but the build failed unconditionnaly with

build script returned non-zero exit code: 127

After reviewing many posts on this subjects, I tried to redeploy the same working commit in my branch by resetting hard and pushin it to my repo

I end up with the same 127 error code

Can you please help. I can’t deploy anymore and it’s really problematic.

Thanks you so much

hi there, could you please link or post your most recent build/deploy log please?

here is one failing

And here is one with the same git commit that built successfully

Alternatively, the one I want to make work is and has the same problem


@perry any idea then ?

hey @martinratinaud,

we made some changes yesterday in an attempt to fix this issue.

Can you try redeploying again, please, and let us know?

Yes it does work now.


do you have a where we can see if everything is working fine?


yes we do! the single source of truth for any system-wide outages is

This specific situation was not a system-wide outage (or an outage that affected more than a very specific group of deploys, which is why it took us a while to realize there was a problem, i’m sorry to hear you were delayed by it), but that is where you can find relevant information.

You absolutely did the right thing - posting here! It was super helpful to have the specific error message you were seeing to debug the deployments that were affected by this issue :+1: