Home
Support Forums

Random 404 error on pages of my site

I’ve had intermittent success with deploying my site today.
Something very odd is now happening; 2 pages in my site are not loading.

My core site is here, and it’s working fine: https://quantizedcrow.com
However, two seemingly arbitrary pages are not loading:
Nourish I: Numbers
and
Old Town Road: Yee Haw Utopia
Everything else is loading though. Literally 20 minutes ago the site was working on my phone and my laptop, and for other people. But now it has stopped working across the board. I then started getting this error from the GitHub page it’s hosted on;


so I did that on Netlify but nothing has changed.
I’m also confused why this suddenly happened and I don’t know if this is something that will fix itself not do I really know what’s wrong with any of this. I’m really scratching my head.

Here’s the github it’s deploying from:

All of the above links are loading fine for me. Is it possible it’s due to some local cache?

This was happening on my mobile device too and another laptop, it seems like these pages are intermittently dropping in and out. I’m not sure if it’s going to happen again or what the cause of it happening initially was either

I just checked and it’s now working again on my phone but not on my laptop, even with incognito/private browser.

When you do get such an error, could you send a HAR file or a x-nf-request-id? More on how to get it here:

This is what I get for the first 404 error:

Summary
URL: Nourish I: Numbers
Status: 404
Source: Network
Address: 185.199.111.153:443

Request
:method: GET
:scheme: https
:authority: quantizedcrow.com
:path: /posts/jun21/nourishi/
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
Accept-Encoding: gzip, deflate, br
Host: quantizedcrow.com
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15
Accept-Language: en-gb
Referer: https://quantizedcrow.com/
Connection: keep-alive

Response
:status: 404
Content-Type: text/html; charset=utf-8
Access-Control-Allow-Origin: *
Age: 1167
Via: 1.1 varnish
Content-Encoding: gzip
ETag: W/“60dddfe4-2174”
Date: Thu, 01 Jul 2021 17:42:31 GMT
Content-Length: 1958
Accept-Ranges: bytes
Vary: Accept-Encoding
x-proxy-cache: MISS
x-cache-hits: 1
Server: GitHub.com
x-github-request-id: 32BC:F8BB:110CB9C:118AA55:60DDF9F8
x-served-by: cache-lon4265-LON
x-fastly-request-id: ccd917df95d433af421b696ac478cddc7cfcdc6f
x-timer: S1625161352.940554,VS0,VE0
x-cache: HIT

And this is what I get for the second:

Summary
URL: Old Town Road: Yee Haw Utopia
Status: 404
Source: Network
Address: 185.199.111.153:443

Request
:method: GET
:scheme: https
:authority: quantizedcrow.com
:path: /posts/jun20/old_town_road/
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
Accept-Encoding: gzip, deflate, br
Host: quantizedcrow.com
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15
Accept-Language: en-gb
Referer: Posts
Connection: keep-alive

Response
:status: 404
Content-Type: text/html; charset=utf-8
Access-Control-Allow-Origin: *
Age: 27
Via: 1.1 varnish
Content-Encoding: gzip
ETag: W/“60dddfe4-2174”
Date: Thu, 01 Jul 2021 17:46:06 GMT
Content-Length: 1958
Accept-Ranges: bytes
Vary: Accept-Encoding
x-proxy-cache: MISS
x-cache-hits: 1
Server: GitHub.com
x-github-request-id: 71D4:B920:D56D93:DBB222:60DDFF43
x-served-by: cache-lon4265-LON
x-fastly-request-id: 85d5ed478a88ef71ad5a76a4a4a447be9822d357
x-timer: S1625161566.022610,VS0,VE0
x-cache: HIT

Hi @NickWerr

You have a CNAME

quantizedcrow.com.	3600	IN	CNAME	nickwerren.github.io.

which is why it says

and not Server: Netlify

Try removing the CNAME record.

I removed the CNAME and redeployed the site, then did the same after removing the ALIAS. Both times were unsuccessful and I just get the following:

Summary
URL: https:// quantizedcrow . com/posts/jun21/nourishi/
Status: 404
Source: Network
Address: 185.199.111.153:443

Request
:method: GET
:scheme: https
:authority: quantizedcrow .com
:path: /posts/jun21/nourishi/
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
Accept-Encoding: gzip, deflate, br
Host: quantizedcrow .com
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15
Accept-Language: en-gb
Referer: https:// quantizedcrow .com/
Connection: keep-alive

Response
:status: 404
Content-Type: text/html; charset=utf-8
Access-Control-Allow-Origin: *
Age: 396
Via: 1.1 varnish
Content-Encoding: gzip
ETag: W/“60dddfe4-2174”
Date: Thu, 01 Jul 2021 23:25:17 GMT
Content-Length: 1958
Accept-Ranges: bytes
Vary: Accept-Encoding
x-proxy-cache: MISS
x-cache-hits: 16
Server: GitHub . com
x-github-request-id: 605E:7793:159FC47:16436CC:60DE4D51
x-served-by: cache-lon4268-LON
x-fastly-request-id: f02af03bc59d9afd5661e990b45a3e3a9ec578f3
x-timer: S1625181918.970274,VS0,VE0
x-cache: HIT

(had to add spaces into the URL so I could reply to you)

Removing the Alias records etc provokes the following error message from GitHub:

(also this post has been marked as spam and hidden?)

Are you hosting your site on Netlify or GitHub Pages?

So I would like my pipeline to be that I push my changes to git, and for the repo to then be deployed by Netlify which ties the domain and deployed site together.

That’s a fairly standard way of working with Netlify. If you are doing that, there is no need for an A, ALIAS, CNAME or any other record pointing to GitHub Pages (i.e. nickwerren.github.io.)

2 Likes