Home
Support Forums

Question: Netlify CMS on localhost is not working

Hi everyone, I’m from Taiwan and not good at English, but I’ll try my best to explain my question.

I use Netlify CMS to build my Hugo website. Everything runs well, but when I want to change and check if the CMS’s configuration and style is okay, I always need to push my repository to Github, which is disturb me a lot.
So I tried to use local_backend: true in admin/config.yml, then used this command: npx netlify-cms-proxy-server.
then the window showed:

info: Netlify CMS File System Proxy Server configured with C:\Users\june.wu\Documents\GitHub\house-blog-hugo-cms
info: Netlify CMS Proxy Server listening on port 8081

It looked it ran successfully on localhost:8081.
But when I type localhost:8081 in browser it showed: Cannot GET /
How can I solve this problem?

You have to run npx netlify-cms-proxy-server alongside your usual command. Open up a new tab in your terminal window and run your static site generator. Then go to localhost:8888/admin/ or whatever port your SSG uses. Just don’t visit port 8081 :slight_smile:

Thanks for your answer!
But I’ve tried this before, and the site became blank.
My screenshot below:

Terminal:

That’s quite unusual. Can you share a repository so I can take a look?

Wait… are there any errors in your browser console when you navigate to /admin/?

Of course.
Here: GitHub - s414june/house-blog-hugo-cms
Thank you a lot! I’m a beginner of programming, so I don’t really know the principle of netlify.
Maybe there is something wrong in my code…

Did you mean this?
image

I meant any other errors. But actually, try disabling your chrome extensions just in case.

Understand. I’ll try it.
There isn’t other error :cold_sweat:

The good news is: There’s nothing wrong with your code, I can run the CMS locally with your repo just fine. The bad news: I’m not sure why you get a blank screen.

The only thing I can think of is that your node-sass is acting up, at least that’s happened to me before. That should throw an error though, so I’m not sure. Maybe try running npm rebuild node-sass. It’s a stab in the dark and it takes a while, but maybe it helps.

2 Likes

InPrivate Page, which is nothing but blank

I’ve tried it, but the admin page is still the same.

Maybe I don’t install netlify-cms completely…
I would do something else first and read more documents later.
Thanks for your reply still.
Now I’m sure the problem isn’t from my repository at least :face_with_monocle:

Any luck when you run npm run start instead of hugo server? (You might have to run npm install first)

1 Like

Oh…I can’t run this command. It’s weird.
image

My mandarin is a little rusty. What does it say in the bottom?

2 Likes

Thanks!
I sloved this problem via npm run start command. (run npm install first)
By the way, I don’t understand why I have to type a trailing slash (/admin/ instead of /admin) because I can only type /admin online and the content manager will work. Anyway, it’s not a big deal.

Glad you’ve got it working. The trailing slash debate is quite elaborate, you can find out more here:

1 Like