Query string functions and Railway 400 Error

Hi, I have an issue with a site I have on Netlify and would greatly appreciate some more brainpower.

https://aprillezammit.com/

As you can see one or more of the components that pull photo urls from the database give a 400 error. On each reload a different component or components error out. The only other console error I get is {"errors":[{"message":"Must provide query string."}]} from the ./netlify/function/graphql. However, there are no errors logged under the Functions > graphql section in the Netlify dashboard.

My database is Postgres on Railway and worked as expected until I upgraded to a paid plan. The only logged error I get there is LOG: could not receive data from client: Connection reset by peer.

When a single component that pulls from the database is on a page by itself, I am not able to reproduce these errors. I have no connection pooling, but do not think that is the issue.

Check under “Student Work”
https://aprillezammit.com/workshops

I have hooked my local version to the live Railway database and everything works exactly as expected with no errors. This is why I feel like I have some sort of configuration issue between Netlify and Railway. What could be going on here? I’d be very grateful for any help!

Is there a way to reproduce this issue? I tried visiting the URL mentioned and don’t see this happening anywhere.