Punycode domain throwing 404

  • Site name: https://storied-mandazi-8ea7b3.netlify.app/
  • Domain: xn–komaja-zrich-klb.ch, ALIAS I have created: komaja-zürich.ch ALIAS https://apex-loadbalancer.netlify.com, I can’t change the source for the ALIAS to for example xn–komaja-zrich-klb.ch. The place I bought the domain automatically has it fixed to what I entered when I bought the domain, which is komaja-zürich.ch. Which I assume is being converted to punycodes behind the scenes?
  • No build command, I only have an index.html file which shows hello world
  • Didn’t try the AI

The better the post - the faster the answer.

When I try to connect to my site it gets served as expected:
x-nf-request-id: 01HZ4KK1MDPXPDX6X54JJNQP67
When I try to connect to komaja-zürich.ch I get the 404 page:
https://apex-loadbalancer.netlify.com/
x-nf-request-id: 01HZ4KNTAPBRNGQMPERP06G09B

Under Domain management I have xn–komaja-zrich-klb.ch configured as my primary site and the awaiting external DNS message also disappeared.

I’m not sure what the problem is, but I assume it has to do with the Umlaut ü.
Let me know if you need more information and thank you for your help

EDIT: I tried now to point komaja-zürich.ch to my site which then prompts me again in the Domain management tab to create an alias from xn–komaja-zrich-klb.ch to https://apex-loadbalancer.netlify.com and not directly to my site. Not sure why that is, I assume apex loadbalances checks where the redirect came from and then know by that to redirect it to my site? But can do load balancing and use the CDN network better then when I directly link it to my site?

The DNS records required do not exist. This is the DNS record for the apex as shown here:

https://toolbox.googleapps.com/apps/dig/#A/komaja-zürich.ch

That is not an IP address associated with Netlify.

For the www subdomain:

https://toolbox.googleapps.com/apps/dig/#A/www.komaja-zürich.ch

no record exists at all:

Please follow the external DNS instructions here:

If there are any questions about those instructions, please let us know.

Thank you for the documentation, I could setup my site to use netlify DNS and at first it still didn’t work, even though Dig (DNS lookup) was showing the NS record existing. I already wanted to write here again, but then after some more hours it worked and my site is being served under komaja-zürich.ch as expected, thank you :slight_smile:

from Imgflip Meme Generator

Hello,

This forums post needs a ticket. I have escalated your concern so that we can better serve you.