Publish_mode doesn't work on /admin/config.toml or /admin/config/yml

I’ve enabled the publish_mode = "editorial_workflow" in my /admin/config.toml file (and also tried the appropriate in config.yaml) but I don’t see post previews or the workflow tab in my site’s admin page. I just set the site up today and then edited the config afterwards. I also tried to deploy with cleared cache to no result.

Have also tried in /config.toml

TOML is probably not a supported file. The other one that you tried is YAML. I think, the file should be config.yml.

Mind sharing your current config?

Hi @hrishikesh, thank you for your help.

I just solved it, it was due to the template that Netlify Hugo uses for the 1-click installs having /admin buried in a different folder. The docs don’t really do a good job of telling you that there’s actually 3 config files:


From the docs, I thought I needed to create a directory /admin/config.yml but that didn’t work and there’s no feedback in the deploy on which config files are being used. It was really quite frustrating having to find out that I needed to go to /site/admin instead of just /admin, like the comment implied:

From the docs:

You can enable the Editorial Workflow with the following line in your Netlify CMS config.yml file:

# /admin/config.yml
publish_mode: editorial_workflow

If you’re using gatsby, add it to your config file in static/admin/config.yml. I was making the mistake of creating a new file at the top level or trying to create an admin directory top level -.-. Hope this helps!