Problems to Identify Git Gateway

Hi i try to search here and in google but i don’t can fix the problem with Netlify Identify. I use netlify cms and netlify identify. I follow the tutorial in Netlify site to setup, but ever i try to access my-site/admin i have this message:
" Unable to access identity settings. When using git-gateway backend make sure to enable Identity service and Git Gateway."
Always, idependent if a repo is new or not
So if ai try to access in my localhost i have this message above, and when i try to access in a deployed site on Netlify, i invite my self and i receive the e-mail confirmation, but when i try to log in, always show me a message: “This Email is not confirmed”
Anyone can help me with this

Hi @lucasfrutig, accessing locally and using the deployed site work a bit different.
Locally the CMS doesn’t know where your site is deployed and it should prompt you to submit your Netlify Site URL. If it doesn’t the site URL is probably cached in local storage and you can clear the storage or delete the netlifySiteURL key from local storage.
For the deployed site:

  1. make sure that there are no DNS errors on Netlify.
  2. curl -i https://<your-site>/.netlify/identity/settings should return a valid response.
  3. curl -i https://<site-id> should return a valid response.
  4. Try accessing the CMS via https://<site-id>
  5. Make sure Netlify identity widget is included in your site under the root path (it includes the code that does the confirmation and confirmation links send you to the root path)

Please let me know how it goes.

1 Like

Hi @erez i delete the netlifySiteURL storage and everything fine now!
Tks so much!

1 Like

Hi @lucasfrutig where can i find the netlifySiteURL?

It’s in your cache / localStorage. Here are some instructions on how to clear it:

1 Like