Home
Support Forums

Pretty URLs trailing slash not playing nice with domain level rewrite

Hi!

I’m trying to migrate from an lambda/s3 setup for deploying and hosting an multilingual, multidomain site. I have so far set up https://www.lapoint.ch so that it deploys and hosts fine. In the build process, we build each language to its own folder in /dist/, and then we deploy the dist folder to netlify.

Using rewrites like
https://www.lapoint.ch/* /de-ch/:splat 200
I make sure the right content is served for each domain. However, we now have everything working both with and without trailing slash. Enabling or disabling pretty URLs have no effect, and we need to 301 to trailing slash.

Any ideas?

Is this thread similar to your request? Consistent trailing slashes on all URLs

Yes but no solution provided for what I’m describing.

Den fre 30 okt. 2020 15:40Hrishikesh Kokate via Netlify Community <netlify@discoursemail.com> skrev:

Well, that I paragraph says it’s not possible. That’s from what I read in the other two posts and understood. You can probably still wait for a more official confirmation.

For my use case it works fine if don’t have the domain to subdirectory rewrite. But I need those. On other sites we’ve deployed we only have one language/domain, so then it works fine.

Den fre 30 okt. 2020 15:55Hrishikesh Kokate via Netlify Community <netlify@discoursemail.com> skrev:

looks like this was resolved in the helpdesk, and i also saw your comment at the end of this thread:

so I am going to close this thread to remove any confusion.