Support Forums

Please read! End of support for Trusty build image: Everything you need to know

Hmm, I don’t entirely understand why I, as a user, need to take action on this. I would understand if I had selected a specific version of Ruby or another dependency, but I never did. As I understand it, a default was assigned when I created the build, and that default is just no longer valid.

What seems proper to me is that I should now get a different default. Sure, people who have specifically selected a different dependency version will need to take action, but those people probably already know that they pinned the dependency version.

In my case, I’d be perfectly happy to have all my defaults blown away and recreated with the latest defaults, that will actually work. Even telling me that you’ll automatically upgrade the versions would be confusing, because I’m not aware of anything like this (“I just used the image and installed my Python package on it, why am I getting a message about Go?”).

1 Like

This is super helpful feedback, thanks for taking the time to share- I’ll pass along to the team that’s working on this

Hi @Stavros,

The build image is like a dependency, and it matters to many people. It’s like upgrading the OS version. The build-in packages will now have a different version, if you’re using legacy tools, they might not work at all with newer versions of the OS and so on. We wanted to give users enough time to make a change - that’s all.

1 Like

@Jinksi, first I must say that I don’t want to speak for @hrishikesh (but clearly people only say that when they are about to). Personally, I’m glad that you took the time to share this and, again - not to speak for him, but I’m fairly sure @hrishikesh is as well. :+1:

Also, not to detract from your effort, but I also wanted to share that @jlengstorf from here at Netlify has created this npm package to migrate all sites on an account to Focal:


No problem! ntl-focal-migrate looks great, a more robust method with account filtering etc.

Thanks @luke and @jlengstorf :+1:

@jamesh you freaking saved me. Thank you :raised_hands:

I had the same error and for some miraculous reason setting the env var RUBY_VERSION to 2.7.0 fixed the build.

This was particularly confusing because my app is a Gatsby application – no ruby is involved or required in our build command.

Hi, If you only use HTML and JavaScript this may work for you:
Step 1: Change from Trusty 14 to Focal 20, Save.
Step 2: Make any changes to the Git repository code to force deploy.
Step 3: Open a beer

:wave: Hey folks, in order to give users more time to migrate their sites, we’ve decided to extend support of the Trusty build image until October 4, 2021.

We’ve also added some indicators in the UI so you can more easily find and update your Trusty sites. In the sites list, sites set to Trusty are marked with a :warning: warning icon.


Clicking the icon opens a tooltip with a link to the site’s build image settings.

We’re also working on some improvements to smooth the experience for sites pinned with an older version of Ruby. Expect another update in a few days!

Update: To ensure a smoother upgrade experience, we are now automatically setting the RUBY_VERSION to 2.7.2 when you upgrade to Focal and we detect that an old version of Ruby is pinned (lower than 2.4). Thanks for your patience and feedback, everyone!