Home
Support Forums

“Page not found” questions for site

Hi @perry and @Scott I am recently running into many 404 out of not where. My setup was working before but now it doesn’t work and I have no idea whats happening. I am also using gatsby-parallel-runner and also I am using incremental builds with netlify-plugin-gatsby-cache

here is the url of one of my deploys: https://app.netlify.com/sites/otakuchan-preview/deploys/5fa8799ce9ded31fc9574ac6 and if you check my account there is lots of deploys with 404 even though there is not errors on the console.

Also when I try to download the files for the deploy I get an error here is a screenshot

here is my account: https://app.netlify.com/sites/otakuchan-preview/deploys.

Also I wasted a lot minutes on this and still not able to deploy my site. Can my timeout limit be increase from 1 hour to 2 hours please?

here is my package.json

{
  "name": "otakuchan",
  "version": "0.0.3",
  "keywords": [
    "otakuchan",
    "frontend"
  ],
  "main": "index.js",
  "repository": "https://github.com/anime-shop-online/frontend",
  "homepage": "https://www.otakuchan.com",
  "license": "MPL-2.0",
  "scripts": {
    "build": "gatsby build",
    "build:incremental": "GATSBY_EXPERIMENTAL_PAGE_BUILD_ON_DATA_CHANGES=true gatsby build --log-pages",
    "develop": "gatsby develop",
    "clean": "gatsby clean",
    "commit": "git-cz"
  },
  "dependencies": {
    "@apollo/react-hooks": "^4.0.0",
    "@emotion/core": "^10.1.1",
    "@emotion/styled": "^10.0.17",
    "@gatsby-contrib/gatsby-plugin-elasticlunr-search": "^2.4.2",
    "@mdx-js/react": "^1.6.21",
    "@n8tb1t/use-scroll-position": "^2.0.3",
    "@reach/visually-hidden": "^0.11.1",
    "@rebass/forms": "^4.0.6",
    "@rebass/preset": "^4.0.5",
    "@sentry/apm": "^5.27.1",
    "@sentry/gatsby": "^5.27.3",
    "@sentry/tracing": "^5.27.3",
    "@theme-ui/presets": "^0.3.0",
    "apollo-cache-inmemory": "^1.6.6",
    "apollo-client": "^2.6.10",
    "apollo-link-context": "^1.0.20",
    "apollo-link-http": "^1.5.17",
    "elasticlunr": "^0.9.5",
    "gatsby-image": "^2.4.21",
    "gatsby-parallel-runner": "^1.3.0",
    "gatsby-plugin-create-client-paths": "^2.3.13",
    "gatsby-plugin-facebook-pixel": "^1.0.3",
    "gatsby-plugin-fullstory": "^2.3.14",
    "gatsby-plugin-intercom-spa": "^0.2.0",
    "gatsby-plugin-lint-queries": "^0.0.3",
    "gatsby-plugin-manifest": "^2.5.2",
    "gatsby-plugin-nprogress": "^2.3.13",
    "gatsby-plugin-react-helmet": "^3.3.14",
    "gatsby-plugin-remove-serviceworker": "^1.0.0",
    "gatsby-plugin-robots-txt": "^1.5.3",
    "gatsby-plugin-sharp": "^2.7.1",
    "gatsby-plugin-sitemap": "^2.5.1",
    "gatsby-plugin-theme-ui": "^0.3.0",
    "gatsby-plugin-web-font-loader": "^1.0.4",
    "gatsby-source-filesystem": "^2.4.2",
    "gatsby-source-shopify": "3.3.2",
    "gatsby-transformer-sharp": "^2.5.21",
    "graphql": "^15.4.0",
    "graphql-tag": "^2.10.4",
    "has-own-prop": "^2.0.0",
    "pure-react-carousel": "^1.27.6",
    "ramda": "^0.27.0",
    "react-apollo": "^3.1.5",
    "react-expand-animated": "^1.0.2",
    "react-ga": "^3.2.0",
    "react-google-recaptcha-v3": "^1.7.0",
    "react-helmet": "^6.1.0",
    "react-loader-spinner": "^3.1.14",
    "react-markdown": "^5.0.2",
    "react-responsive-tabs": "^4.1.1",
    "react-share": "^4.3.1",
    "react-social-icons": "^4.1.0",
    "react-toastify": "^6.1.0",
    "react-use": "^15.3.4",
    "rebass": "^4.0.6",
    "shopify-buy": "^2.11.0",
    "simple-react-lightbox": "3.3.4-2",
    "theme-ui": "^0.3.1",
    "util": "^0.12.1"
  },
  "devDependencies": {
    "@babel/core": "^7.12.3",
    "babel-eslint": "^10.0.3",
    "babel-plugin-emotion": "^10.0.21",
    "commitizen": "^4.2.2",
    "cz-conventional-changelog": "^3.3.0",
    "eslint": "^7.13.0",
    "eslint-config-airbnb": "^18.2.1",
    "eslint-config-prettier": "^6.15.0",
    "eslint-config-react-app": "^6.0.0",
    "eslint-plugin-flowtype": "^5.2.0",
    "eslint-plugin-graphql": "^4.0.0",
    "eslint-plugin-import": "^2.22.0",
    "eslint-plugin-jsx-a11y": "^6.4.1",
    "eslint-plugin-prettier": "^3.1.4",
    "eslint-plugin-react": "^7.21.5",
    "eslint-plugin-react-hooks": "^4.2.0",
    "gatsby": "^2.25.3",
    "react": "^17.0.1",
    "react-dom": "^17.0.1"
  },
  "peerDependencies": {
    "gatsby": "^2.13.38",
    "react": "^16.8.6",
    "react-dom": "^16.8.6"
  },
  "config": {
    "commitizen": {
      "path": "./node_modules/cz-conventional-changelog"
    }
  }
}

Hi, @daiky00. Did you try downloading the deploy? The 404 is because there is file at /index.html for that deploy. I’ve increased the build time limit to two hours for that site also.

If there are other questions or concerns, please let us know.

what do you mean there is a file in index.html? I try downloading the deploy but I was running into a error if you check my original post here is an image:

Hi, @daiky00. It was a typo. I meant to write there is no file at /index.html file for that deploy.

Regarding the failed deploy download, my best guess is that is because of the size of the deploy. The deploy in question contains 17630 files with a total byte count of 1433307725 for all files.

Again, the page not found for the deploy in question is occurring because there was no /index.html file generated for this deploy.

If there are other questions, please let us know.