Home
Support Forums

Page Not Found, but deployment looks correct

I downloaded my deploy, and I do have my index.html file included, yet still have “Page Not Found”. I am sure that i am missing something.

Welcome to the forums @jeremyberry

Is the index.html in the root of your project (e.g. NOT site/index.html)?
Is it index.html and not index.html.html? (Note: file extensions are often hidden by default.)
Have you deployed from a git repository? If so, can you share it?

I depolyed from bitbucket. To be honest I am new with this all but I believe it is not in my root, but unsure how to debug.

If you Bitbucket repository is public, can you share the URL for it?

If you have downloaded your site and unzipped it, can you shared a screenshot of the contents?

the index.html is not in the root of project. So how would I make it so that it is?

You might have a directory (in Bitbucket) that looks like this:

.
├── css
│   └── custom.css
├── images
│   └── image.jpg
├── index.html
└── js
    └── somefile.js

so that index.html is in the root of your repository, thus the root of your site.

I am still not sure on how to solve this issue. I appreciate your time and help.

You have two options:

  1. Move everything inside jeremy-berrys-dev-portfilio.webflow up one level into the root of your projects.
  2. Change the Publish directory under Site settings > Build & deploy as per image

I tried option two, and it was unsuccessful. My apologies, but would you be able to walk me through option one?

The easiest option is to Sourcetree to clone your repository, in Finder move all your files up one level, and push back to Bitbucket. There is no way in Bitbucket website to move an entire directory (that I have found.)

Thank-you so much for your help!

1 Like