Page not found, after deployement

netlify site name :

error message :Page Not Found
Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.

Deploy log:
7:53:09 PM: Build ready to start
7:53:11 PM: build-image version: d2c6dbeac570350a387d832f64bc980dc964ad65 (focal)
7:53:11 PM: build-image tag: v4.8.0
7:53:11 PM: buildbot version: a0072c9aa857edb8d0052da6c6482646b4348b94
7:53:11 PM: Fetching cached dependencies
7:53:11 PM: Failed to fetch cache, continuing with build
7:53:11 PM: Starting to prepare the repo for build
7:53:11 PM: No cached dependencies found. Cloning fresh repo
7:53:11 PM: git clone GitHub - Matthieudegny/ATOM
7:53:12 PM: Preparing Git Reference refs/heads/main
7:53:12 PM: Parsing package.json dependencies
7:53:13 PM: No build steps found, continuing to publishing
7:53:13 PM: Starting to deploy site from ‘’
7:53:13 PM: Creating deploy tree
7:53:13 PM: Creating deploy upload records
7:53:13 PM: 0 new files to upload
7:53:13 PM: 0 new functions to upload
7:53:13 PM: Starting post processing
7:53:13 PM: Finished processing build request in 2.62115322s
7:53:13 PM: Post processing - HTML
7:53:13 PM: Post processing - header rules
7:53:14 PM: Post processing - redirect rules
7:53:14 PM: Post processing done
7:53:16 PM: Site is live :sparkles:

Hello, i dont understant why i cant find a way to publish my app, its workinl locally but not with netlify, i have a file index.html in the repo public, and my file server.js is the repo pilot
you can check my github for the code repo ATOM GitHub - Matthieudegny/ATOM
could you advice me, how i can fixe this please

Hey there, :wave:

Thanks for reaching out! I took a look in your repo and do not see an index.html. Check out this Support Guide for some insights on how to fix this!

you mean at the root of the repo?
Because i have an index.html file, as mentioned in my message
“have a file index.html in the repo public, and my file server.js is the repo pilot”
your reponse is absolutly not helpfull for me,
could you just advice, where i can find informations, i read your link and find nothing
Thank you


I just looked at the repository and I see no index.html in the root of the repository, and do not see one in the public directory either.

Repository Root:

public directory:

Additionally, if you are trying to run a server, you might like to read the following Support Guide which will explain why this will not work

The link provided by Hillary is very much relevant in this instance. Please show a little more courtesy to the community at large in future posts.

1 Like

thank you for your resposne coelmay, i made several test with teh drag and drop method, i just commut the change home.html → index.html
could you check again pleaase
i retry using to host using the github link, and still not working,
thank you

What are the build settings you used?

node js app, with express i start the app with npm start,
i dont know if it is the response you were asking?

i read your link and may be it is an netlify function i need in this case, no?

Have you tried setting the publish directory to public?

you mean, in github? iyes its already set as public

No. I mean in the build settings in the Netlify UI.


its what i got, i gonna check it right now

i change the publish directory to public, still not working, do i need to retry the hosting with those setting?

Yes, you need to redeploy after changing the settings.

coelmay you are the best helper in the world, thank you mate, i pay you a beer next time wee meet

i probably miss an other step, when i click on the link in my website its give me an error message, site unreachable, do i need to set the route?


If you look at the by date and by text links, they point to http://localhost:3000