Home
Support Forums

Page is blank after succesful deploy

Hey, I’ve deployed from github-pages repo to this url
https://dreamy-poitras-604192.netlify.app/

and the page is blank with an error
GET https://dreamy-poitras-604192.netlify.app/portfolio/css/app.9331c7dc.css net::ERR_ABORTED 404

Since I deployed from github-pages repo directly I didnt include any build script or directory, but I also tried deploying from master branch with npm run build and dist/ directory and still the same…

here’s the repo link if that helps.

Are you directly publishing your public folder in the first method that you mentioned? If yes, it indeed doesn’t have a CSS file.

Hi, @Peppek1993. My best guess is that your build command (which is currently blank) should be “npm run build”. The publish directory setting should be “public”. Both settings can be added here:

https://app.netlify.com/sites/dreamy-poitras-604192/settings/deploys#build-settings

(Leave the base directory blank, by the way.)

If that doesn’t resolve the issue, please let us know.

Changed the command to npm run build and directory to public and it’s still the same :frowning:

I tried to do it all again from scratch and still nothing. I’m using vue-cli if that helps

The website works just fine on github-pages

Hiya, sorry you are having trouble with your build.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

Hey, I managed to fix the issue.
I had a vue.config.js file that contained

module.exports = {
  publicPath: process.env.NODE_ENV === 'production'
    ? '/' + process.env.CI_PROJECT_NAME + '/'
    : '/'
}

from previously deploying to github-pages. I deleted the file and the page deployed as it should.

2 Likes