Ntl dev: Waiting for localhost never connect

Using netlify-cli v 2.11.10 everything worked fine. Upgraded to 2.25 and now it just hangs on โ€œWaiting for localhostโ€

FWIW I tried downgrading back to 2.11.10 and it still does not work, so maybe the upgrade is unrelated :man_shrugging:

This is a fairly simple Nuxt app using lambda-functions to process Stripe payments. Is there someway to have a verbose log or something so that I can see where itโ€™s getting hung up?

timeout problem

Waiting for localhost:3333.
โ—ˆ Lambda server is listening on 65010
yarn run v1.21.1
$ nuxt
   โ”‚                                             โ”‚
   โ”‚   Nuxt.js v2.11.0                           โ”‚
   โ”‚   Running in development mode (universal)   โ”‚
   โ”‚                                             โ”‚
   โ”‚   Listening on: http://localhost:3333/      โ”‚
   โ”‚                                             โ”‚

Waiting for localhost:34567.โ„น Preparing project for development                                                                                                                                                            17:21:15
โ„น Initial build may take a while                                                                                                                                                               17:21:15
โœ” Builder initialized                                                                                                                                                                          17:21:15
โœ” Nuxt files generated                                                                                                                                                                         17:21:15

โœ” Client
  Compiled successfully in 8.66s

โœ” Server
  Compiled successfully in 7.93s

โ„น Waiting for file changes                                                                                                                                                                   17:21:24
โ„น Memory usage: 247 MB (RSS: 396 MB)                                                                                                                                                           17:21:24


  command = "yarn dev" # Command to start your dev server
  port = 3333 # Port that the dev server will be listening on
  functionsPort = 34567 # port for functions server
  targetPort = 3333 # Port of target app server
  autoLaunch = true # a Boolean value that determines if Netlify Dev launches the local server address in your browser

  command = "node ./create-env.js && cat ./.env && yarn generate"
  publish = "dist"
  functions = "functions"

Blerg same as https://github.com/netlify/cli/issues/659 like a lot of other people are running into. Rolled back to v2.12.0 fixed it for me.

Also, found how to print out debug info by reading the docs (who knew!)

For anyone else that finds this: DEBUG=* ntl dev dis the trick

1 Like