Not seeing any collections in the admin dashboard

Briefly summarize the issues you have been experiencing.

I’ve set up and deployed a NextJS site on Netlify using this doc:

For some reason, I don’t see any collections when I go to the admin dashboard even though I set one up in my config.yml and content/

Also, when I go to localhost:3000/admin I see a 404 error/ “page not found”. It looks like someone asked this question before here: Admin page says 404 not found

Please provide a link to your live site hosted on Netlify

What have you tried as far as troubleshooting goes? Do you have an idea what is causing the problem?

I’ve tried googling this issue but haven’t found anything helpful. I’m not sure what is causing the problem.

Do you have any other information that is relevant, such as links to docs, libraries, or other resources?


@jennyr would be great if you could show code or a link to a public repository.

Need to do a local build and make sure the /admin path exists in the build.

I’m getting a 404 Page not found error in http://localhost:3333/admin

The link to the public repo/branch which has been deployed to Netlify is here.

The config.yml (which was using git-gateway/master, but I changed to test-repo and the branch name):

  # If you want to test changes made to your config.yml file locally: 
  # Swap out "git-gateway" with "test-repo" and 
  # Navigate to localhost:3333/static/admin/index.html to view Netlify CMS locally. 
  name: "test-repo"
  branch: netlify-cms
  # This line should *not* be indented
media_folder: static/images/uploads
  - name: "pages"
    label: "Pages"
    - label: "Home"
      name: "home"
      file: "content/"
        - { label: "Title", name: "title", widget: "string"}
        - { label: "Publish Date", name: "date", widget: "datetime" }
        - { label: "Body", name: "body", widget: "markdown"}
        - label: 'Cats'
          name: "cats"
          widget: list
            - { label: "Name", name: "name", widget: "string"}
            - { label: "Description", name: "description", widget: "text"}

There’s definitely content on the homepage, but it’s not appearing in the admin.

From the url in the last image you posted the path is /static/admin and not /admin

Like I was saying earlier, you could try a build local and see how your site builds out the folder structure for deploy. Basically run your build command instead of your dev command.