Home
Support Forums

Node version issues: Build script returned non-zero exit code: 1

2:09:36 PM: curl: (56) GnuTLS recv error (-54): Error in the pull function.

2:09:36 PM: Binary download from https://nodejs.org/dist/v10.16.0/node-v10.16.0.tar.xz failed, trying source.

2:09:36 PM: grep: /opt/buildhome/.nvm/.cache/src/node-v10.16.0/node-v10.16.0.tar.xz

2:09:36 PM: : No such file or directory

2:09:36 PM: failed during stage 'building site': Build script returned non-zero exit code: 1

2:09:36 PM: Provided file to checksum does not exist.

2:09:36 PM: Failed to install node version '10'

2:09:36 PM: Error running command: Build script returned non-zero exit code: 1

2:09:36 PM: Shutting down logging, 2 messages pending

Same here. No idea how to fix.

Same here this is what I’m seeing across ALL site redeploys.

Version ‘10’ not found - try nvm ls-remote to browse available versions.
Version ‘8’ not found - try nvm ls-remote to browse available versions.

We have the same problem on our frontend.

2:14:23 PM: Version '8' not found - try `nvm ls-remote` to browse available versions.
2:14:23 PM: Failed to install node version '8'
2:14:23 PM: Error running command: Build script returned non-zero exit code: 1
2:14:23 PM: failed during stage 'building site': Build script returned non-zero exit code: 1
2:14:23 PM: Failing build: Failed to build site

I’ve had the same issue so I’ve asked support about this and I got following response:
“We’ve identified the issue as being related to nvm or nodejs and the incident their hosting provider is experiencing: https://www.cloudflarestatus.com/incidents/46z55mdhg0t5”. (edit: fixed link)

1 Like

Looks like it is fixed now. We had a successful deploy on our staging site. :fireworks:

The problem is gone for me too. Thanks for letting me know I wasn’t alone so I didn’t have to spend more time debugging this.

hi everyone, as mentioned above, this was an issue related to a third party and should be resolved now. Please let us know if you have any more trouble.

Hey @perry, is there an aftermath?

Our builds are failing with repeated npm errors of this kind for diff packages:

6:59:42 PM: Computing checksum with sha256sum
6:59:42 PM: Checksums matched!
6:59:45 PM: Now using node v10.16.0 (npm v6.9.0)
6:59:45 PM: Attempting ruby version 2.3.6, read from environment
6:59:46 PM: Using ruby version 2.3.6
6:59:46 PM: Using PHP version 5.6
6:59:46 PM: Started restoring cached node modules
6:59:46 PM: Finished restoring cached node modules
6:59:47 PM: Installing NPM modules using NPM version 6.9.0
7:00:00 PM: npm
7:00:00 PM:  WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/webidl-conversions-f578d840/package.json'
7:00:00 PM: npm
7:00:00 PM: WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/webidl-conversions-f578d840/README.md'
7:00:00 PM: npm WARN
7:00:00 PM: tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/webidl-conversions-f578d840/LICENSE.md'
7:00:00 PM: npm
7:00:00 PM: WARN tar
7:00:00 PM:  ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/react-dom-2b8261c0/umd/react-dom-unstable-fire.production.min.js'
7:00:00 PM: npm
7:00:00 PM:  WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/bootstrap-3419c89a/dist/js/bootstrap.js'
7:00:01 PM: npm WARN tar
7:00:01 PM:  ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/zxcvbn-546799cc/src/main.coffee'
7:00:01 PM: npm
7:00:01 PM: WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/zxcvbn-546799cc/src/matching.coffee'
7:00:01 PM: npm
7:00:01 PM: WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/onfido-sdk-ui-70dedb4a/dist/reports/statistics.html'
7:00:01 PM: npm
7:00:01 PM: WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/zxcvbn-546799cc/src/scoring.coffee'
7:00:01 PM: npm
7:00:01 PM:  WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/zxcvbn-546799cc/src/time_estimates.coffee'
7:00:01 PM: npm
7:00:01 PM: WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/zxcvbn-546799cc/.zuul.yml'
7:00:01 PM: npm WARN tar
7:00:01 PM:  ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/eslint-0536df2f/lib/rules/init-declarations.js'
7:00:01 PM: npm
7:00:05 PM: failed during stage 'building site': Build script returned non-zero exit code: 1
7:00:01 PM: WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/eslint-0536df2f/lib/rules/jsx-quotes.js'
7:00:01 PM: npm

They were working earlier today.

Rebuilding with clean cache doesn’t help.

Can you provide a link to one of your failing deploys @stefanmaric? Thanks.

Shared them in private. :slight_smile:

Whenever we see this pattern in a build failure:

7:00:00 PM: npm
7:00:00 PM: WARN tar
7:00:00 PM:  ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/react-dom-2b8261c0/umd/react-dom-unstable-fire.production.min.js'

It is almost always one of two things:

  1. your package-lock.json needs to be rebuilt - it refers to some temporary files that are not present during our build. This is the usual reason for that type of error.
  2. Less common, you’ve for some reason committed your node_modules directory to git, which is an antipattern for building on Netlify. Let package-lock.json or yarn.lock do their jobs and specify versions for you and we’ll fetch them. Of course this won’t work well when Cloudflare is down, but that’s the main reason it should fail…
1 Like

Indeed. :pensive:

It was actually related to this issue, in case someone else is looking for it: https://github.com/faye/websocket-driver-node/issues/34

Some package lingering in the npm registry for longer than it should (like a whole extra week).

1 Like

hey @tyholby, this error is a pretty generic one that can pop up for a variety of reasons. If you can paste your deploy log or link us to it, we can take a closer look.

If you think npm is having issues, this is the best place to check:

https://status.npmjs.org/

I’m experiencing the issue at the moment.

2:37:28 PM: Version '10' not found - try `nvm ls-remote` to browse available versions.
2:37:28 PM: Failed to install node version '10'
2:37:28 PM: Error running command: Build script returned non-zero exit code: 1```
1 Like

I am experiencing the same issue. Any ideas how to fix?

Same here. Suddenly deploys fail with error shown above about node version 10.

There is nothing you can do to work around it. It is due to the outage on the internet, that is preventing our loading of node. More details on our statuspage:

https://netlifystatus.com

The root cause seems to be what is described in this thread at hacker news, if you’d like to see the scope: https://news.ycombinator.com/item?id=24322513

I’m having a similar issue! Any ideas would be appreciated!

Hi @EMMA1,

Looks like you’ve got a reply there, let us know if that works and let’s continue the discussion in a single thread.