No redirect rules processed; simple redirect

Trying to test out redirects.

My netlify page: https://blissful-bohr-5ece0e.netlify.app

My _redirects.txt which is in /public folder:"/* https://www.petsofnetlify.com 301"

All i am trying to do is to redirect all traffic to another site. However when I deployed I get No redirect rules processed in the deployment summary

hi there, the correct filename for redirects is just _redirects not _redirects.txt

can you try with the correct filename? that might be all you need to do differently.

1 Like

Hi,

Indeed it worked. The deploy summary now says 1 redirect rule processed. however, my page still doesn’t redirect to the page specified?

Thanks!

ok! well some progress at least.

before we dig in, I strongly suggest you give it a thorough read through and see if this fixes your problem:

if not, please post again, and we’ll try and troubleshoot.

Hi, I have read throught this guide and some of the attached documentation but still am a bit stuck.

I read that I have to have a custom domain so I am moving to my main project which contains a primary domain which I am trying to redirect the netlify.app subdomain to.

I have successful added a redirects file and it works when I type specific URLs into my browser for example Equity Framework will indeed redirect to Equity Framework

But the default subdomain does not redirect to my primary page?

See some lines from my _redirects file which should be doing what I want above:

https://bchc-inequities-project.netlify.app/ https://www.covid-inequities.info/ 301

Thanks for the help again!

Have you tried force? That is, https://bchc-inequities-project.netlify.app/ https://www.covid-inequities.info/ 301!.

You can also try: https://bchc-inequities-project.netlify.app/* https://www.covid-inequities.info/:splat 301!

1 Like

Ahhh. Worked like charm.

I have seen the ‘!’ in other posts but was not sure what it did. Now it makes sense. Thanks for the clarification!