"No build command found, continuing to publishing" Build stuck at building phase

Please let me know if you find any workaround this issue

Same issue with my site. Looks like a Netlify problem rather than something our config is causing.

How are other people’s sites setup? Just wondering if the issue is with Netlify talking to Git as our site is setup to build automatically from a Git repository

hi there, sorry that some of you are experiencing problems!

In order to troubleshoot, can everyone who is having the same problem please share:

  • their most recent deploy log (link or paste here)
  • their netlify site name

so we can take a look. thanks.!

can you also all post a screenshot of your build settings and your package.json please so we can take a look at your build commands? thanks.

4:17:09 PM: Build ready to start
4:17:11 PM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6
4:17:11 PM: build-image tag: v3.4.1
4:17:11 PM: buildbot version: 0e3cc7aef5c33f731b54ed4b65d515eaab821679
4:17:11 PM: Fetching cached dependencies
4:17:11 PM: Starting to download cache of 3.6MB
4:17:11 PM: Finished downloading cache in 135.391171ms
4:17:11 PM: Starting to extract cache
4:17:11 PM: Finished extracting cache in 56.404739ms
4:17:11 PM: Finished fetching cache in 193.005852ms
4:17:11 PM: Starting to prepare the repo for build
4:17:12 PM: Preparing Git Reference refs/heads/master
4:17:13 PM: No build command found, continuing to publishing
4:17:14 PM: Finished processing build request in 2.647261839s

it shows deploy in progress even though it finished processing. Reason?? @luke

hi there, I am moving this to a thread re: similar issues, as you are not the only person experiencing this.

I had to update an old website that in the past was hosted by Netlify.
Yestarday I’ve updated my bitbucket repo and created a new website in Netlify.
Unfortunately the building process gives no error but does not stop:

11:21:25 AM: Preparing Git Reference refs/heads/AltriTest
11:21:18 AM: Build ready to start
11:21:19 AM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6
11:21:19 AM: build-image tag: v3.4.1
11:21:19 AM: buildbot version: 0e3cc7aef5c33f731b54ed4b65d515eaab821679
11:21:19 AM: Fetching cached dependencies
11:21:19 AM: Failed to fetch cache, continuing with build
11:21:19 AM: Starting to prepare the repo for build
11:21:20 AM: No cached dependencies found. Cloning fresh repo
11:21:20 AM: git clone git@bitbucket.org:fa-runci/projectnadia
11:21:26 AM: No build command found, continuing to publishing
11:21:28 AM: Finished processing build request in 8.512245402s

Do you know what is the issue? The building remains in progress but logs state it has finished.
This is a static website with a normal index.html (built with HTML) .

Thank you,

Hey ! Same thing for me, yet last week everything was working perfectly. I hope we’ll have a solution soon.

Same question: Build status not changing from "Building"

Hello, my app arpitdalal.netlify.app is not building since this morning (3rd October 2020). It’s last successful built was on 1st October 2020. The issue isn’t that build is failing, in fact, if that was an issue, it could have been an easy fix but here the status is not changing from “Building” I have tried triggering a manual build but that didn’t help either. My builds are directly linked to my pushes on my git repo, the app is recording my pushes to the git repo but the status of build is remaining “Building” no matter what. I was hoping to get help with this.
Thank you in advance.


Same problem here with lot of sites.
It finishes build (no build in our case) but by some reason it’s not deploying at all.

Eg.: https://app.netlify.com/teams/ecomplus-bot/builds/5f791fa3ae6fb28ef4efa6fe

1 Like

I am also experiencing the same issue.

I’m also facing this issue.

Tried searching for this issue but not finding anything relevant.

I’ve been using Netlify for a long time with no problems deploying my sites, but recently I am unable to deploy and unsure why.

Here is an example of a failure, it appears to hang after building and stops short of deploying.

10:53:19 PM: Build ready to start
10:53:20 PM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6
10:53:20 PM: build-image tag: v3.4.1
10:53:20 PM: buildbot version: 0e3cc7aef5c33f731b54ed4b65d515eaab821679
10:53:20 PM: Building without cache
10:53:20 PM: Starting to prepare the repo for build
10:53:21 PM: No cached dependencies found. Cloning fresh repo
10:53:21 PM: git clone https://github.com/bennettfeely/bennett
10:53:22 PM: Preparing Git Reference refs/heads/master
10:53:24 PM: No build command found, continuing to publishing
10:53:28 PM: Finished processing build request in 7.958018777s

And that’s it. This occurs with a git-initiated deploy, when retrying the deploy, and clearing the cache and retrying the deploy.

I’ve tried re-deploying a previously successfully published build and it is hanging there too.

URL is https://bennettfeely.com (bennettfeely.netlify.app)

Thanks a lot!

1 Like

Hi, i have the same problem… :sob:

I have sent a message to netlify support


1 Like

yaya, which site do you have a problem with? thanks.

hi all, i am gathering threads here from the various folks who have been experiencing this issue. We are aware of the problem and are investigating, I’ll get you more more updates as we know more. Stay tuned - and thank you for your patience as we look into this.



@perry Thanks for the reply. Info attached/below:

Site name: advertorial-immediate
Live URL: https://advertorial.immediate.co.uk/
Most recent deploy log: https://app.netlify.com/sites/advertorial-immediate/deploys/5f7b464da591100088f41ac5
Successful deploy log example: https://app.netlify.com/sites/advertorial-immediate/deploys/5f774403dbd68f000794a349
Build settings screenshot:

Package.json: { "name": "new-feature", "version": "1.0.0", "description": "", "main": "index.js", "scripts": { "test": "echo \"Error: no test specified\" && exit 1" }, "author": "", "license": "ISC", "devDependencies": { "browser-sync": "^2.26.7", "gulp": "^3.9.1", "gulp-autoprefixer": "^5.0.0", "gulp-cssnano": "^2.1.3", "gulp-inject-string": "^1.1.1", "gulp-plumber": "^1.2.0", "gulp-sass": "^4.0.1", "gulp-tinypng": "^1.0.2", "run-sequence": "^2.2.1" } }