NextJS 14 deployment failed!

Deploy logs looks good but I’m not reach deploy preview and I am encountering an error like this:

enable-pre-post-scripts=true
engine-strict=true
public-hoist-pattern[]=*
registry=https://registry.npmjs.org/
user-agent=pnpm/8.8.0 npm/? node/v18.17.0 darwin arm64

URL to check this please?

Hi Hrishikesh, I think there are problems about Netlify deployment with NextJS’s version 14 and above. So I downgrade to NextJS 15.3.4 and solved the deployment issue.