Newly added CNAME Netlify hosted Subdomain 404ing (primary and sub domain's DNS hosted in Cloudflare)

Hi Guys

I’ve been trying to get a subdomain (https://dashboard.lex.lawyer) of my main domain (https://www.lex.lawyer) to work with no success.

Both sites are hosted in netlify from a github repo, the DNS is provided by cloudflare thought.

https://www.lex.lawyer was and is working, this morning I tried to add the dashboard app we built by adding a CNAME to Cloudflare , specifically dashboard pointing to the url that netlify provides: ie. mysitename.netlify.com but the site is continuously responding with a 404.

Not to mention I tried with both Cloudflare proxy on and off…

Any suggestions would be more than welcome.

Thanks in advance!

Hi @MelMacaluso,

That domain is loading for me:

image

And the DNS looks good as well:

host dashboard.lex.lawyer
dashboard.lex.lawyer is an alias for frosty-bassi-952711.netlify.com.
frosty-bassi-952711.netlify.com has address 167.99.4.63
frosty-bassi-952711.netlify.com has IPv6 address 2604:a880:400:d1::8b0:4001

Are you still having trouble?

Hi @futuregerald, thanks a lot for your help, yes, I had to be a little bit more patient. Thanks!

Hello,

I’m having this exact problem and I have been waiting for at least a day for the changes to appear. My subdomain is community.paypack.rw

runnning host community.paypack.rw yields:

Hi, @quarkssgroup. Looking at the account history, the issue was that the custom domain was never added to the site here:

https://app.netlify.com/sites/paypack/settings/domain#custom-domains

The DNS record is not enough. You must all add the custom domain to the site settings above also and this was not done.

If there are other questions or concerns, please let us know.