Home
Support Forums

New site deploy not working

https://practical-jepsen-7ba6bb.netlify.app/

I deployed this site the same way I always do. I select new site from git, select the repo I want to link it to and hit deploy. This has always worked but this time I get this message.

Writing a detailed post will help us solve your issue faster, generally speaking we need this:

  • Netlify Domain (.netlify.app)
  • Git Repo if you have one
  • Latest deploy logs (either copy and pasted or linked to)

Kyle.

I already posted the domain above. Here is the rest:

1:55:49 PM: Build ready to start
1:55:51 PM: build-image version: 653805ca4a64301556e56dc4b321ef8fc20cbb7c
1:55:51 PM: build-image tag: v3.8.2
1:55:51 PM: buildbot version: 5ca46ad10ed1b3bf6d683d62872e59029498e5a4
1:55:51 PM: Fetching cached dependencies
1:55:51 PM: Failed to fetch cache, continuing with build
1:55:51 PM: Starting to prepare the repo for build
1:55:52 PM: No cached dependencies found. Cloning fresh repo
1:55:52 PM: git clone GitHub - gtrman97/weather_app
1:55:52 PM: Preparing Git Reference refs/heads/master
1:55:53 PM: Parsing package.json dependencies
1:55:53 PM: No build steps found, continuing to publishing
1:55:53 PM: Starting to deploy site from ‘/’
1:55:53 PM: Creating deploy tree
1:55:53 PM: Creating deploy upload records
1:55:53 PM: 0 new files to upload
1:55:53 PM: 0 new functions to upload
1:55:53 PM: Starting post processing
1:55:53 PM: Post processing - HTML
1:55:53 PM: Post processing - header rules
1:55:53 PM: Finished processing build request in 2.519845957s
1:55:53 PM: Post processing - redirect rules
1:55:53 PM: Post processing done
1:55:54 PM: Site is live :sparkles:

Mmm… it looks like a pretty simple site so there isn’t any issue with framework setup etc.

Could you please post your build settings found under…
deploys > deploy settings > build settings

Just checked over your repo, there is no index.html in your project root. Simply change weather.html to index.html as well as the file links… and everything should be good.

See this here

We attempt to serve only /index.html in case you try to load your site without a path

Kyle.

1 Like