Home
Support Forums

New page in NetlifyCMS not rendering List widget

I can’t get a list widget to render in Netlify CMS for a newly generated page. The page itself renders fine and I’m not getting any config error messages when loading the CMS, I can log in fine on both localhost and from within Netlify itself and see everything. I’ve got other list widgets rendering fine in the same site.

I’m getting no console errors and 200 status for all files in Network tab.

I post below the relevant entry in my config.yml file which shows 3 different attempts, each are rendering identicallly in the CMS. Following that is a screengrab of the CMS showing the missing list widget.

The content/texts dir exists and I’ve made 3x .md files which correctly reflect the entries in the config.

collections:
... ... other entries etc.

  # Texts
  - label: 'Texts 01'
    name: 'textsListCategory'
    summary: 'Insert link to website or PDF'
    folder: 'content/texts'
    format: 'frontmatter'
    fields:
      - label: 'Text Listings'
        name: 'textsListObject'
        widget: 'object'
        collapsed: true
        fields:
          - label: 'Text Listing'
            name: 'textsList'
            widget: 'list'
            fields:
              - {
                  label: 'Web or PDF',
                  name: 'textsListItem',
                  summary: 'Insert link to website or PDF',
                  widget: 'text'
                }

  - label: 'Texts 02'
    name: 'textsListCategory02'
    summary: 'Insert link to website or PDF'
    folder: 'content/texts'
    format: 'frontmatter'
    fields:
      - label: 'Text Listing 02'
        name: 'textsList02'
        widget: 'list'
        fields:
          - {
              label: 'Web or PDF',
              name: 'textsListItem02',
              summary: 'Insert link to website or PDF',
              widget: 'text'
            }

  - label: 'Texts 03'
    name: 'textsListCategory03'
    summary: 'Insert link to website or PDF'
    folder: 'content/texts'
    widget: 'list'
    fields:
      - {
          label: 'Web or PDF',
          name: 'textsListItem03',
          summary: 'Insert link to website or PDF',
          widget: 'text'
        }
... ... other entries.

//////////

Here’s what shows in the CMS on both localhost and within Netlify:

Texts 01/02/03 are all the same as this and clearly there’s no list widget rendering. Can anyone see any glaring ommission in my config?

Many thanks in advance

Hi there!

Thanks for your interest in Netlify CMS. Looks like you posted your question a little while ago, but that you haven’t received a solution yet. Here’s where you might get more help:

netlifycms.org - the site houses our extensive documentation that likely contains helpful information to get you back on track.

netlify cms slack - join our friendly slack channel and chat with other cms pros to get the help you need.

GitHub Issues - think you’ve found a bug, or would like to make a feature request? Make your voice heard here. Netlify CMS is open source - PRs and other contributions are also welcome!

Stack Overflow Check StackOverflow for questions tagged “Netlify CMS” if you don’t get an answer in the Slack or the GH issues. StackOverflow reaches a worldwide audience of knowledgeable people.

Your question will be left open here for anyone to comment - but we encourage you to check out the above resources if you are still looking for a solution!

Hi there,

Thanks for following this up, nice to know the forum is monitored. I will refer to these links but in the meantime I am trying to get this fixed myself in available time with different approaches. Will write here if/as/when it works but time is quite limited on this one right now.

1 Like

Thanks for letting us know! Do follow up if you find a solution :slight_smile: