Home
Support Forums

New blog article does not show even after completing publish process

This is my netlify site name : hopeful-wright-a67925

I cannot see my new article even after completing publishing process by netlify side.
When I compare the log with previous one, I noticed that today:s deployment is missing these logs.
(seems there is no error, just missing some processes below)


Starting post processing*
Post processing - HTML*
Post processing - header rules*
Post processing - redirect rules*
PM: Post processing done*

I don:t know why my today:s deployment is missing these, I am exactly doing the same thing like last time.
Can you check the deployment scripts or if I do any wrong please kindly give me some advises, thank you so much!

Hi @kzyrepository,

It seems strange. The deploy logs for the first deploy with commit message add 1 article show that 15 new files were uploaded, however the next 2 deploys for the same commit show that 0 new files were uploaded. This would mean that the files were correctly uploaded in the first time. Is there a repo that we can check to advise?

Hi hrishikesh san

Thank you so much for your response, I just tried one more but only the new article does not show (modifying the article already deployed can show the change)
Only new files deployment seems to have the problem.

Unfortunately, my repo is private so I cannot share it, do you have other reports like me at the moment?
I will also try to find the solution, thank you so much

2021年6月14日(月) 19:55 Hrishikesh Kokate via Netlify Support Forums <netlify@discoursemail.com>:

Unfortunately, no. This seems like a weird issue that’s affecting your website only (or at least that’s the only reported case at the moment).

If you can’t share your private repo, you could probably set-up a test repo that has the issue same as yours so we can debug.

thank you for your response.

I just created the repo for investigation.
Can you take a look at it?

https://bitbucket.org/kzyrepository/test-netlify-error-for-new-file/src/master/

test.md is the file not shown on my prod ENV.

For your reference, I list up what I investigated below.

  • I checked bitbucket log and the added file was uploaded successfully
  • on local ENV. I can see the article
  • only prod env and only new file cannot be shown even though the deployment log says successful

Thank you for your support!

2021年6月14日(月) 21:14 Hrishikesh Kokate via Netlify Support Forums <netlify@discoursemail.com>:

Hi @kzyrepository,

I’d assume it’s because of the timezone you’ve mentioned in the file. The system timezone might not be UTC + 7, thus the file is treated as a file in the future. You have 2 options: tell Hugo to build future posts by changing your build command to hugo -F or by removing the time from the file.

Again, it’s just an assumption and it might not be the problem at all. Do let us know how it goes.

ThAnk you so much!
That’s was exactly the root cause ( I set the time date 2 days forward)

I reverted the time setting and now everything worked, I really appreciate for your support!

I will remove the repository as well later
Best regards