Netlify no longer detecting forms

I’m having an issue where all previously-known-working forms are no longer being detected during the build and deploy process. All forms contain the necessary Netlify-related tags, but no longer get picked up. I can still see the forms listed in the user control panel, and are reported as “collecting data”.

<form id="question" class="question" name="question" method="POST" netlify-honeypot="bot-field" data-netlify="true" action="/thanks">

The forms themselves will correctly redirect to the “/thanks” url, however it will show the 404 page content. Refreshing the page correctly loads the contents of “/thanks”.

I’ve looked at the deploy logs and found the last deploy that correctly picked up the forms, and compared and reviewed the changes but still cannot get the forms to process properly.

Nothing from the forms code has changed, it’s simply baffling me.

Also, taking a look in the deploy log, I don’t see my forms listed there anymore! They all properly contain the data-netlify=“true”, however none are being detected.

Hey there, @RT_Hinkel :wave:

Thanks for reaching out! Sorry to hear you are encountering this issue.

I see that you currently have an open Helpdesk ticket, so I am going to ask that you continue this conversation there. This will ensure that we are streamlining communication.

In the interim, this Support Guide is the first port of call to debug any forms issues. Please give this a read if you haven’t already. At the bottom of this article it asks for the following information:

  1. The URL for your live form as you want visitors to use it
  2. The URL of your deployed html form. In case you have a javascript form, we need to literally be linked to the html version you’ve deployed, as mentioned above (look for “ pure javascript form ”)
  3. The form name that you’ve set and that shows in our UI
  4. Any errors or logs from the Netlify build logs, dashboard or browser developer console
  5. Description of anything you have tried that did or didn’t help or make things better/worse

If you have not already, please go ahead and share that information in your open Helpdesk ticket so that the Support Engineer who works with you has the details they need.

My apologies— I appreciate the reply.

I solved the issue by enabling --minify in the build settings. (Hugo)

I am so glad to hear you found a solution! Thanks for sharing, it will definitely help future Forums members should they encounter something similar :netliconfetti: