Home
Support Forums

Netlify lm:setup gives an error on last step. Configuring Git to use Netlify's Git Credentia l Helper


this is the error I am getting while trying to run set up for large media. I also tried running the command with sudo but there’s some error in PATH that I am not able to understand.
my site name is kanas-two.netlify.app

Hi @afsheen

Have you tried reading through [Support Guide] Troubleshooting your Netlify Large Media Configuration?

Not yet, I’ll go and try right now. Thanks!

Hi, @afsheen. It does appear the netlify command cannot read the .gitconfig file in your home directory.

You can see the permissions with the command below:

ls -l ~/.gitconfig

What are the permissions for that file on your system?

Hi luke, thanks for helping out. turns out the support guide link helped out. my netlify folder’s path was different and I just had to set it. there is new error however, but I think that is also explained in the link above, I’ll try that and reach out if I wouldn’t be able to. Thanks again

hello luke. so the 1st issue is solved. but the 2nd one - Provisioning Netlify Large Media
→ Large Media addon doesn’t support manual dep-, is what I am currently stuck at I know the path to my netlify helper folder, my OS is Big Sur and my shell is zsh. What do I do?
edit: I did run the command suggested in the terminal. source path to my path.zsh.inc file, I still have that error. and my file permissions are “-rw-r–r–”

Hi @afsheen

Just clarifying, are you saying your site is not connected to a git provider (GitHub, GitLab, Bitbucket)?

Hi, @afsheen. Are you trying to do manual deployments? If so, using Large Media isn’t possible as it is a Git LFS service and only works for deploys that build at Netlify using a Git repo for deployment.

it is connected to GitHub repo for ci. but the site has not been deployed yet. is that the reason?

It is connected to GitHub but to not deployed yet on netlify, its linked locally only.

Yes, so I thought I had connected the repo but I had not. I am trying to deploy from ui now but the build is failing with exit code: 2. @coelmay and @luke

LFS only works once deployed (as I understand), not in a purely local environment.


this is my deployment error from netlify. what can I do about this?

Hi, @afsheen. The error says the file ./src/logo.svg is missing. Does the file exist at that location? Is that the exact name of the file (logo.svg and not Logo.svg) as well?

Also, if you post the deploy id or the full logs for the deploy (as text not a screenshot, as there is no way for us to copy/paste text from a screenshot) we should be able to provide more assistance.

hello, @Luke thanks a lot for your reply, I fixed the above error. but I don’t need large media anymore. how do I uninstall it and delete the plugin from my current website? my site id is:
cd3b5304-e96f-42ed-ba4a-f5058018bba1

Hi, @afsheen. First, you are discussing this in to different threads. The other thread can be found here:

I’m going to follow-up in the thread above and please do not cross-post questions (posting the questions about the same issue in more than one topic) in the future.