Netlify Identity issues for several days and in multiple Identity instances

Hi there,

This entire week I’ve been having trouble with Identity, after it had been working fine for months.

Here’s the problem:

  1. Sometimes the problem is a CORS thing, and I get the dreaded Access to fetch at [X] from origin [Y] has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. If an opaque response serves your needs, set the request's mode to 'no-cors' to fetch the resource with CORS disabled.

  2. Other times I get Internal Server Error - Request ID: [Z]

  3. And yet other times it says the resource basically doesn’t exist.

This has been going on in two separate Identity instances, as far as I can tell:

  1. The one I’m most concerned about is (primary domain, branch subdomains and

  2. This is also happening in

Based on my investigations, here are my conclusions:

  1. It’s not about the package I’m using (react-netlify-identity-gotrue), because the problems also happen with the official netlify-identity-widget and when I make an API call directly.

  2. It’s not about local development, because the problems happen on the production sites as well, and also when I make API calls from Reqbin or Postman.

  3. It’s not about my machine, because it works on and off in the exact same browser and device just minutes apart.

  4. It’s not about using custom domains or having branch subdomains, because the problem also happens in

Fixes I’ve tried so far:

  1. Adding an Access-Control-Allow-Origin header rule to netlify.toml

  2. Including the official widget script in my <head> tag even if I use the React-specific package

  3. Using the widget instead of the React-specific package

  4. Deleting and recreating the Identity instance

  5. Using no-cors mode in API calls

  6. Some other stuff I can’t even remember right now

I’ve Googled far and wide and read and tried pretty much everything at this point, but I feel like the problem is quite probably on Netlify’s end.

Any help would be appreciated!

Hey @xurxe,

At the moment, it seems like Identity service is broken for several users. We’ve already filed an escalation for our engineers to look at and we’d update the thread as soon as we have some news.


Hi @xurxe,

Our team has updated us, and this should be working now. Please let us know if you’re still having issues.

1 Like