Home
Support Forums

Netlify functions build error

Hi, we are working on a Netlify Functions API, and we started getting a strange build error a couple of commits ago.

The error is:

8:09:12 AM:   Dependencies installation error
8:09:12 AM:
8:09:12 AM:   Error message
8:09:12 AM:   A Netlify Function failed to require one of its dependencies.
8:09:12 AM:   Please make sure it is present in the site's top-level "package.json".
8:09:12 AM:   In file "...path_to_function.js"
8:09:12 AM:   Cannot find module 'superagent-proxy'

The API was working fine and then it started with that error. That dependency is not being used by us, at least not directly, maybe it’s a dependency from another dependency.

The site is flamboyant-brattain-8123b7.

Thanks in advance

For some reason regenerating the yarn.lock fixed the problem, so that was the issue.

2 Likes