Netlify Form issue

Hello there,

I have an 11ty theme I used for most of my websites, I had built several sites with this theme, the issue is that some sites won’t submit the form while others will, even tho they shared the same code.
Here is the sample of the code…

<form name="form_contact" method="POST" data-netlify="true" action="/thank-you/index.html"
    class="form-contact" 
    data-netlify-honeypot="bot-field">

        <input type="hidden" name="form-name" value="form_contact" />

        <label for="name" class="hidden-by-ux">Your Name</label>
        <input 
          type="text"
          name="name" 
          placeholder="John Doe"
          minlength="0" 
          maxlength="32"
          title="Name"
          required
        />

        <label for="email" class="hidden-by-ux">Your E-mail</label>
        <input 
          type="email"
          name="email"  
          placeholder="john@mail.com"
          minlength="6" 
          maxlength="32"
          title="Email"
          required
        />
        
        {# <p id="response"></p>   #}

        <button type="submit">Subscribe  &#8594;</button>
  </form>

once the form is submitted it won’t redirect anywhere and it will give me an error page but the form would be in the netlify dashboard.

Is there any specific reason why i have this issue?

Hiya, sorry you are having trouble getting your forms to work.

This Support Guide is the first port of call to debug any forms issues. There are also many other Support Guides for forms - you can find them here: #Netlify-support:support-guides

We also recommend trying to search the forums or look at topics tagged Netlify forms if you haven’t already - it’s likely your question was already asked by someone else!

If you are still having problems, please provide more information such as what you have already tried, and a link to your live form. :slight_smile:

I’m not sure but it seems to be an issue with any site that has the domain name connected with Namecheap.

hey there, i’m not sure how those two could be connected, but if you tell us which domain this is regarding, we can at least take a look at your domain settings for you!

I have several site hosted by Netlify… so far the only one able to submit form is my portfolio which domain name belongs to GoDaddy, the rest of the site belongs to Namecheap and non of them submit the form

Thanks for your time, I already figured out the issue,
It had to do something with the server worker, I had to deactivate it and now it works.

1 Like