Home
Support Forums

Netlify form doesn't send attached file

Thank you for all your help, Netlify is a great product and always helpful.
However, there is one problem that I cannot solve.

I’m trying to use Netlify Form to receive files, but it’s not stable.
It’s not stable.
It succeeds only once after deployment, and fails the rest of the time.
The files I want to receive are simple image files (jpg, png).
The situation is similar to this thread.

I have tried what this forum says.
I’ve even put tags inside tags.

But I still can’t figure out how to solve the problem.
Can you please help me?

The site I’m testing is as follows.
Sorry for the Japanese.
The relevant part is at the bottom of the page.

I’ve also extracted the HTML from this site.

Professional help is needed.
I’ll try to help as much as I can.

hi there, just a quick note to say we haven’t forgotten about you! i hope we have some more information on this soon.

Hi @ratte,

When you say you don’t receive the file, are you sure the file has been uploaded? I can see, in the last 5 submissions, 2 came out without any image. Is there any validation on the form that prevents a submission if a file is not attached?

Hello, @hrishikesh
Thank you for the reply. This is my other account.
I’m sorry for the delay in my reply. But the problem is not solved.

There is no validation, and uploading files is optional for users.
When I select the image file from my PC and send it, it does not appear to be uploaded in the admin panel. That field appears to be blank.

If you have any idea what’s going on, I’d appreciate it if you could let me know.

Hiya, thanks for following up on this thread! Sorry to hear you are having trouble getting your forms to work.

This Support Guide is the first port of call to debug any forms issues. Have you already read this? It walks through some step by step debugging strategies for forms issues. There are also many other Support Guides for forms - you can find them here: #Netlify-support:support-guides

If you have read that support guide and followed the suggestions, please reply with the following information:

  1. The URL of your deployed html form. In case you have a javascript form, we need to literally be linked to the html version you’ve deployed, as mentioned above (look for “ pure javascript form ”)
  2. The form name that you’ve set and that shows in our UI
  3. Any errors or logs from the Netlify build logs, dashboard or browser developer console
  4. Description of anything you have tried that did or didn’t help or make things better/worse