Home
Support Forums

Netlify doesn't detect (or my domain registrar doesn't) detect my http url

I noticed that typing “tetizeraz.online” in the browser redirected to my domain registrar Hostinger. But I already did change my DNS there to the DNS provided by Netlify, and they work in “www.tetizeraz.online” and “https://tetizeraz.online”, but not the http link.

These are the options my domain registrar gives me. There’s no mention of A record, AAA record, or CNAME, that kind of stuff.

Hi @Tetizeraz

It is default behaviour for most newly registered domains to point to a landing page with the registratar.

DNS does take time to propagate, which it appears to have done now; I can access https://www.tetizeraz.online/ and https://tetizeraz.online/ (which redirects to the former.) If you are having issues still, could you try a different browser, a private/incognito window, or a different device as the old page is possibly cached locally.

You are using Netlify DNS now, so if you need to add any of these records, you will do so via the Netlify UI and not your registrar.

Oh, it seems it’s a browser behaviour. On Google Chrome tetizeraz.online (without “www” or “https://”) actually reaches the site correctly. It’s only on Firefox, apparently, that tetizeraz.online redirects to the http site, which is parked on Hostinger.

Can I fix this for Firefox, or is that on Firefox’s side to fix?

Time will fix it.

However, if you wish to give things a little push, in Firefox Preferences > Privacy & Security > Cookies and Site Data select Clear Data.

(Note: ensure only Cached Web Content is checked or you will have to log into every website you use again.)