Home
Support Forums

Netlify Dev server not starting for Hugo site

My site is skyglass.netlify.app. My site is using Hugo. I have linked my local repo with my site (netlify link) but when I run netlify dev it doesn’t start the server on port 8888.

Version info: netlify-cli/6.14.21 darwin-x64 node-v17.0.1

The first time I try after rebooting my machine, the Hugo server launches on port 1313. When I navigate to localhost:1313 in my browser, it triggers the Netlify server to launch on port 8888 and opens that page in browser. From there, everything works as expected.

However, after killing the server, if I run netlify dev again, I can’t get the Netlify server to start. I just get:

◈ Netlify Dev ◈
◈ Injected netlify.toml file env var: HUGO_VERSION
◈ Injected build settings env var: EMAILOCTOPUS_API_KEY
◈ Injected build settings env var: EMAILOCTOPUS_LIST_ID
◈ Ignored general context env var: LANG (defined in process)
◈ Loaded function subscribe.
◈ Functions server is listening on 50035
◈ Starting Netlify Dev with Hugo
Start building sites … 
hugo v0.88.1+extended darwin/amd64 BuildDate=unknown

                   | EN  
-------------------+-----
  Pages            | 34  
  Paginator pages  |  0  
  Non-page files   |  0  
  Static files     | 81  
  Processed images |  0  
  Aliases          | 10  
  Sitemaps         |  1  
  Cleaned          |  0  

Built in 338 ms
Watching for changes in /Users/ryan/Code/skyglass-web/{archetypes,assets,content,data,layouts,package.json,static,themes}
Watching for config changes in /Users/ryan/Code/skyglass-web/config.toml
Environment: "development"
Serving pages from memory
Running in Fast Render Mode. For full rebuilds on change: hugo server --disableFastRender
Web Server is available at //localhost:1313/ (bind address 127.0.0.1)
Press Ctrl+C to stop

I’m expecting this instead (this is from the first run after a reboot):

◈ Netlify Dev ◈
◈ Injected netlify.toml file env var: HUGO_VERSION
◈ Injected build settings env var: EMAILOCTOPUS_API_KEY
◈ Injected build settings env var: EMAILOCTOPUS_LIST_ID
◈ Ignored general context env var: LANG (defined in process)
◈ Loaded function subscribe.
◈ Functions server is listening on 49501
◈ Starting Netlify Dev with Hugo
Start building sites … 
hugo v0.88.1+extended darwin/amd64 BuildDate=unknown

                   | EN  
-------------------+-----
  Pages            | 34  
  Paginator pages  |  0  
  Non-page files   |  0  
  Static files     | 81  
  Processed images |  0  
  Aliases          | 10  
  Sitemaps         |  1  
  Cleaned          |  0  

Built in 339 ms
Watching for changes in /Users/ryan/Code/skyglass-web/{archetypes,assets,content,data,layouts,package.json,static,themes}
Watching for config changes in /Users/ryan/Code/skyglass-web/config.toml
Environment: "development"
Serving pages from memory
Running in Fast Render Mode. For full rebuilds on change: hugo server --disableFastRender
Web Server is available at //localhost:1313/ (bind address 127.0.0.1)
Press Ctrl+C to stop

   ┌─────────────────────────────────────────────────┐
   │                                                 │
   │   ◈ Server now ready on http://localhost:8888   │
   │                                                 │
   └─────────────────────────────────────────────────┘

My netlify.toml is:

[build]
  publish = "public"
  command = "hugo"
  functions = "functions"

[build.environment]
  HUGO_VERSION = "0.74.3"

[dev]
  framework = "hugo"

It’s a known issue with Node 17. Could you add the relevant details here: